You are not logged in.

#1 2023-01-04 12:08

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Upgrade to a newer Q4OS edition

This recommendation concerns an upgrade from older Q4OS edition, for example Q4OS 4 Gemini / Debian Bullseye to a newer one for example Q4OS 5 Aquarius / Debian Bookworm.

First, we always recommend a new fresh Q4OS installation and copying desired user data in the $HOME folder, as it ensures the clean operating system base and exclude possible hidden inconsistencies. In such a clean way, it could be feasible to make use of custom profiles feature of the Desktop profiler, see https://www.q4os.org/dqa016.html

For those, who really want to do a regular upgrade:
The upgrade will be possible according to the standard conditions of Debian. If you follow recommendations for Debian and simply modify Q4OS repositories in sources.list, it should be possible to upgrade between Q4OS editions in most cases. Keep in mind, the major upgrades usually require post-upgrade manual system interventions and fixes, what could be time consuming. Some hidden inconsistencies may also persist after upgrade, and show themselves later unexpectedly.

Q4OS 4 -> Q4OS 5 see https://www.q4os.org/forum/viewtopic.ph … 337#p24337

Do not hesitate to post any valuable links to Debian upgrade instructions in the follow up discussion.

Offline

#2 2023-03-22 16:25

just1acc
Member
Registered: 2023-02-23
Posts: 27

Re: Upgrade to a newer Q4OS edition

Very good topic. Lets have some informative discussions before Q4OS 5

Offline

#3 2023-03-22 16:49

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,320

Re: Upgrade to a newer Q4OS edition

The upgrade section here is quite useful. https://www.debian.org/releases/stable/ … ase-notes/

The process of just upgrading Debian is normally pretty easy.

There are additional factors with pinning in Q4OS and other bits and bobs discussed in the notes that do make me wonder about the wisdom of going down the upgrade route with Q4OS.

Perhaps the question is whether the devs have the bandwidth to make the process foolproof or not. The more you try to cater for exceptions the worse it gets.....

In the past I have always just bit the bullet and reinstalled. I have a list of the packages I install so that doesn't take long. Keeping the old config files is easy enough in just backing up the dot files.
OK there's a bit of fiddling with a few system files I adjust but TBH it's no big deal.

It would be nice to get a test version of Q4OS 5 to play with.

Offline

#4 2023-03-22 17:43

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: Upgrade to a newer Q4OS edition

Upgrade Q4OS 4 -> Q4OS 5

Q4OS 5 will not use any APT pinning by default, so upgrade of Q4OS specific system part should comprise of the following steps at least:
- Edit "/etc/apt/sources.list.d/10_q4os.list" and change "q4os-4-0-cn" to "q4os-5-0-cn"
- If you are not using Trinity DE, just delete the "/etc/apt/sources.list.d/12_qtde.list" file
- If you are using Trinity DE, edit "/etc/apt/sources.list.d/12_qtde.list" and change line:

deb http://q4os.org/qtderepo bullseye basic main"

to

deb http://q4os.org/qtderepo bookworm main

Don't forget to remove the "basic" component.

- Remove Q4OS pinning by deleting file "/etc/apt/preferences.d/pin80-q4os"

- Continue upgrading the Debian part, at the first place you  need to edit "/etc/apt/sources.list.d/20_debian.list" and change repositories from "bullseye" to "bookworm" according to Debian instructions.

Be ready, some applications may be muddled when using configurations from older versions. Q4OS specific tools and applications should receive the upgrade peacefully, however we are not able to guarantee so for all situations.

Last edited by q4osteam (2023-03-23 11:43)

Offline

#5 2023-03-23 06:58

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,320

Re: Upgrade to a newer Q4OS edition

Thanks for that info. Chicken and Egg question....?

I would be tempted to do the Debian dist-upgrade first, on the basis that everything in the existing TDE side should work fine with a later version of Debian libraries. The reverse may or may not be true.

Once the OS is updated I would then do TDE.

Offline

#6 2023-03-23 11:48

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: Upgrade to a newer Q4OS edition

@bin
Q4OS 5 compiles TDE libraries against the new Debian version, so the old ones likely will not work flawlessly in a mixed environment. So, the upgrade should be performed at once, as close as possible.

Important note: don't try to upgrade now, until Q4OS 5 is released. Q4OS 5 repositories are not initialized at the moment.

Offline

#7 2023-10-26 10:17

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

HI! I Have a Problem

- Edit "/etc/apt/sources.list.d/10_q4os.list" and change "q4os-4-0-cn" to "q4os-5-0-cn"

I`m here now in Terminal

### Q4OS essential repositories

## origin q4os.org | o=q4os.org,a=q4os-4-0-st,n=q4os-4-0-cn,l=q4os-4-0 reposito>
deb xxxx://q4os.org/q4repo q4os-5-0-cn main
##deb-src xxxx://q4os.org/q4repo q4os-5-0-cn main

^G Hilfe     ^O Speichern ^W Wo ist    ^K Ausschneid^T Ausführen ^C Position
^X Beenden   ^R Datei öffn^\ Ersetzen  ^U Einfügen  ^J Ausrichten^_ Zu Zeile 

Now how can I save this please? Thanks


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

#8 2023-10-26 10:29

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: Upgrade to a newer Q4OS edition

HerrAbisZ wrote:

Now how can I save this please? Thanks

Just press ctrl+O as suggested ... "^O Speichern"

HerrAbisZ wrote:

^G Hilfe     ^O Speichern ^W Wo ist    ^K Ausschneid^T Ausführen ^C Position
^X Beenden   ^R Datei öffn^\ Ersetzen  ^U Einfügen  ^J Ausrichten^_ Zu Zeile

Offline

#9 2023-10-26 12:49

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

Aha! not Zero but O and then "enter"

q4osteam wrote:

- If you are using Trinity DE, edit "/etc/apt/sources.list.d/12_qtde.list" and change line:

deb xxxx://q4os.org/qtderepo bullseye basic main"

to

deb xxxx://q4os.org/qtderepo bookworm main

That is what i see

GNU nano 5.4                               /etc/apt/sources.list.d/20_debian.list
### Debian essential repositories

## origin deb.debian.org | o=Debian,a=stable,n=bullseye,l=Debian,c=[main|contrib|non-free],b=[amd64|i386|arm64|armhf]
deb xxxx://deb.debian.org/debian bullseye main contrib non-free
##deb-src xxxx://deb.debian.org/debian bullseye main contrib non-free

## origin security.debian.org | o=Debian,a=stable-security,n=bullseye-security,l=Debian-Security,c=[main|contrib|non-free]>
deb xxxx://security.debian.org/debian-security bullseye-security main contrib non-free
##deb-src xxxx://security.debian.org/debian-security bullseye-security main contrib non-free

## origin deb.debian.org | o=Debian,a=stable-updates,n=bullseye-updates,l=Debian,c=[main|contrib|non-free],b=[amd64|i386|a>
deb xxxx://deb.debian.org/debian bullseye-updates main contrib non-free
##deb-src xxxx://deb.debian.org/debian bullseye-updates main contrib non-free

## origin deb.debian.org
##deb xxxx://deb.debian.org/debian bullseye-proposed-updates main contrib non-free
##deb-src xxxx://deb.debian.org/debian bullseye-proposed-updates main contrib non-free

q4osteam wrote:

- Remove Q4OS pinning by deleting file "/etc/apt/preferences.d/pin80-q4os"

I see this

Explanation: increase q4os repo priority
Explanation: to be preferred to debian
Explanation: ---
Package: *
Pin: release o=q4os.org,n=q4os-2-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-3-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-4-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-5-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-rpi-2-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-rpi-3-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-rpi-4-0-cn
Pin-Priority: 501

Package: *
Pin: release o=q4os.org,n=q4os-rpi-5-0-cn
Pin-Priority: 501

And i can`t delete them


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

#10 2023-10-26 13:03

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

UH Sorry, wrong List

GNU nano 5.4          /etc/apt/sources.list.d/12_qtde.list
### Q4OS-TDE repositories

## origin q4os.org | o=q4os.org,a=qtde-bullseye-st,n=bullseye,l=Q4OS TDE reposi>
deb deb xxxx://q4os.org/qtderepo bookworm main
##deb-src deb xxxx://q4os.org/qtderepo bookworm main


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

#11 2023-10-27 15:47

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

I Have something from here

xxxxx://www.q4os.org/forum/viewtopic.php?id=3887

Now i will see


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

#12 2023-10-27 15:53

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

does not work because the addresses are not correct


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

#13 2023-11-05 16:03

HerrAbisZ
Member
Registered: 2023-10-26
Posts: 28

Re: Upgrade to a newer Q4OS edition

It`s ok, but 5.2 isn`t stable on Aspire 5715Z


BITTE helft einander! Mehr auf meinem Blog http://herrabisz.wordpress.com/ http://www.youtube.com/user/HerrAbisZ2 + 3

Offline

Board footer

Powered by FluxBB