You are not logged in.

#1 2022-04-23 20:34

fotafm
Member
From: Stafford, VA
Registered: 2022-04-23
Posts: 1

No internet (unknown host) after fresh install (Newbie)

To demonstrate the utility of Q4OS Linux to a local PC Users Group, I installed Q4OS 4.7 Gemini 32-bit with Trinity Desktop Environment on an ancient laptop (i.e., HP OmniBook XE2 with a 450 MHz PIII CPU and 256 MB RAM).

Since this laptop lacks an Ethernet connection, I obtained access to the internet using a USB to Ethernet adapter.  I subsequently installed the Synaptic Package Manager, Kazam screen capture utility, and AbiWord.  The process on this ancient system took ~1.5 hours.

I unplugged the laptop intending to obtain screen captures the following day for my Workshop presentation and found that the internet connection was down "Unknown Host."  The ethernet cable was checked and it's sending data; I checked it at the switch.  I tried a different cable, a different USB to Ethernet adapter, and a PCMCIA to ethernet adapter with no success.  I noted the computer asked for date and time to be set upon reboot and I assumed the BIOS battery is dead in this laptop.

Thinking that the OS was corrupted in some way, I tried to reinstall Q4OS.  However, I was unable to configure the desktop because no active Ethernet connection was detected.  At this point I am stumped.

I am not intimately familiar with Debian Linux and have limited experience using Q4OS (i.e., a few system installations).  My experience using Debian-Linux is with Open Media Vault for a home NAS/Server.  I assume you need output from a series of Linux commands to assist me to troubleshoot the connection difficulties.  If I don't get access to the internet soon, I will have to install Q4OS on a more modern system to evaluate it for my Workshop or present my difficulties with this Q4OS install to a group of PC enthusiasts.  Without internet access, apps cannot be installed and the system cannot be configured or updated.  I know the system is capable, as I've installed Q4OS on it as described above.  However, my reinstallation attempt has failed.

Can anyone in the forum help me troubleshoot my internet access problem?

Respectfully,


"Any sufficiently advanced technology is indistinguishable from magic." -- Arthur C. Clarke

Offline

#2 2022-09-22 01:02

Toshiba3000
Member
From: Spain
Registered: 2022-08-19
Posts: 11

Re: No internet (unknown host) after fresh install (Newbie)

Hi, here are some tips for your old computer.

Your laptop really needs a hardware upgrade to work properly with Q4OS. Corruption is easier to get with lack of RAM memory. 256 Mb is really the minimum size to install Q4OS. you could try older versions (Centaurus 3.8 is fine)  to install the system into your laptop with minimal specs, but ethernet connection will run full of lags if you keep outdated your laptop from some hardware improves you could try.

Your processor is slow, needs max RAM config specs at full speed to work properly. Firefox or Chrome browsers needs minimun 1 Gb RAM to run, and sometimes lags and hangs can be found  because navigation requirements are usually higher than minimal specs.

Your laptop is old but can be useful if you upgrade at maximun speed its RAM modules [see hardware specs of your laptop, usually RAM upgrade is possible up to 1 Gb,].

Also, try to buy a new hard disk adapter size 2,5" inches which allow m.2 hard disks to install into. This  adapter has an IDE connector (44pin). Depending on your laptop hardware specs,  this kind of disk could be fine for you, or maybe a SSD with SATA connectors. Any both of them you choose and fit on your computer will improve definitely your laptop. The cheaper m.2 disk you find to buy is more than enough for this kind of old computers, no matter about speed writing they have, it will better enough than old traditional hard disks 2/5". Same thing with SSD disks.

Try to install a plug and play wifi usb. Not very expensive to find. It will improve your internet connection. No need to install nothing when you connect it after Q4os system first installation. Also a usb to ethernet adapter could help, you obtain up to 1000 mbts/s of downloading, and it is some cheaper than usb wifi adapters.

A good internal cleaning and new thermal paste on the processor avoid the system gets heating which makes slower your computer. The cleaner laptop makes the faster laptop with no heat.

That is all I did on my Toshiba 3000 PIII, Processor 1000Mhz,  1 Gb RAM, to make it work properly under Q4OS. Since then. works like a charm everything. No internet lags, no corruption files anymore.

Without these improves related above, you hardly could run your laptop in an acceptable way with Q4os. My laptop is x2 faster than your 450 Mhz processor, I had to do all these changes to work decently with it. Not until you upgrade your RAM hardware, traditional hard disk to m.2 and a good internal cleaning with new thermal paste, you will enjoy Q4OS on your laptop.
This is the way I think it has to be done with Q4OS over old computers.

Last edited by Toshiba3000 (2022-09-22 02:18)

Offline

Board footer

Powered by FluxBB