You are not logged in.

#1 2017-09-07 13:27

Jerome
Member
Registered: 2016-02-26
Posts: 104

Program won't launch from desktop icon

I have compiled some software from source (configure, make, make install) but when I tried to run it I got an error about not being able to find a shared object even though I had added the location to my PATH (the shared object is in /usr/local/lib). After some googling I discovered that for library files you need to use the variable LD_LIBRARY_PATH, not PATH, for shared objects. So I added this line to my .bashrc:

export LD_LIBRARY_PATH=/usr/local/lib

The program now runs ok but only from a terminal, not from a desktop icon. I see there is an option to enable launch feedback but where can I see it? Any suggestions? Thanks.

Offline

#2 2017-09-07 23:04

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 1,535
Website

Re: Program won't launch from desktop icon

If your program works from the command line, I can't see any reason why it shouldn't work from a desktop link.

How do you have the link set-up?

Sometimes you will need to give the "work path" to the link so it knows where in the system it should be working, I had this happen once and simply entered my home directory as the work path and it then worked without issue.

There is also an option to run your link in a terminal under the advanced options, but it would really depend upon your application as to whether this is relevant.

Offline

#3 2017-09-08 09:28

Jerome
Member
Registered: 2016-02-26
Posts: 104

Re: Program won't launch from desktop icon

Thanks for replying. No I can't see any reason why it shouldn't run from the desktop link if it works from the command line either. I set up the link from the start menu, using right-click and 'add item to desktop'. Anyway I solved the problem by recompiling the software and installing into my home folder rather than /usr/local.

Offline

#4 2017-09-08 22:37

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,324
Website

Re: Program won't launch from desktop icon

Jerome wrote:

The program now runs ok but only from a terminal, not from a desktop icon. I see there is an option to enable launch feedback but where can I see it?

You probably need to edit the application shortcut, the '.desktop' file, and modify 'Exec=' line the following way:

Exec=LD_LIBRARY_PATH=/usr/local/lib <original_command>

You can also specify to launch a program in terminal by adding line:

Terminal=true

Offline

Board footer

Powered by FluxBB