You are not logged in.

#1 2016-11-13 13:51

Jerome
Member
Registered: 2016-02-26
Posts: 125

Can't install VLC

I've recently installed the new version 1.8 and am getting an error trying to install VLC from the software center. After 52% I got this message:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
q4os-vlc : Depends: vlc but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Testing installation ... Done

I also tried to install mplayer

sudo apt-get install mplayer
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
mplayer : Depends: libmp3lame0 (>= 1:3.99.0) but 3.99.5+repack1-7+deb8u1 is to be installed
E: Unable to correct problems, you have held broken packages.

Last edited by Jerome (2016-11-13 15:22)

Offline

#2 2016-11-13 15:32

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

By the way, I've been doing a bit of googling on this and some seem to recommend using aptitude instead of apt-get for fixing these dependency problems. Not sure what the difference is between them though.

Also, can installing 3rd party deb files mess up your system? The reason I reinstalled q4os was because I had downloaded some deb files for a compiler (free pascal compiler and Lazarus IDE) and installed them using dpkg -i, then I got an update which removed Lazarus and also replaced the version of the compiler with an older one. After trying to sort out the mess I gave up and reinstalled q4os from scratch.

I think maybe my current issues with the broken packages have something to do with this.

Offline

#3 2016-11-13 15:39

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

I have vlc installed on my system ok and have libmp3lame0 version 3.99.5+repack1-7+deb8u1, you could try installing libmp3lame0 first and see if it works then.

EDIT: Fixing broken packages would be a priority! IIRC there is a q4 script that will help, but I can't recall it off-hand...
running sudo apt-get -f install should fix the problem though

Last edited by Dai_trying (2016-11-13 15:43)

Offline

#4 2016-11-13 15:45

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

Hi Dai_trying, thanks for the suggestion but I already tried it:

sudo apt-get install libmp3lame0
Reading package lists... Done
Building dependency tree
Reading state information... Done
libmp3lame0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

Go figure...

Offline

#5 2016-11-13 15:47

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

what does apt list --upgradable give you?

Offline

#6 2016-11-13 15:58

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

I get this:

fpc/jessie-backports 3.0.0+dfsg-9~bpo8+1 i386 [upgradable from: 3.0.0]
N: There are 2 additional versions. Please use the '-a' switch to see them.

fpc is the free pascal compiler I referred to above, and which I installed from a deb file I downloaded directly from the Lazarus web site. I didn't realize the latest version was in backports.

Last edited by Jerome (2016-11-13 15:59)

Offline

#7 2016-11-13 16:01

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

I would remove your version and the install the proper debian version. with a little luck it might solve the vlc issue at the same time smile

Offline

#8 2016-11-13 16:16

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

You may be right, but I think I'll wait for some input from q4osteam first. I don't want to mess up again.

Offline

#9 2016-11-13 16:55

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

Dai_trying wrote:

I would remove your version and the install the proper debian version. with a little luck it might solve the vlc issue at the same time smile

Yes, it's the right way to solve this issue, thanks Dai_trying.

Jerome wrote:

I had downloaded some deb files for a compiler (free pascal compiler and Lazarus IDE) and installed them using dpkg -i...

If you install a .deb files from Debian incompatible sources you could expect 'broken dependencies' errors.

Jerome wrote:

You may be right, but I think I'll wait for some input from q4osteam first. I don't want to mess up again.

In case you are using Q4OS/Debian repositories, don't worry to proceed 'apt-get' operations, you cannot mess your system anyway.

Offline

#10 2016-11-13 16:57

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

Dai_trying wrote:

... there is a q4 script that will help, but I can't recall it off-hand...

$ sudo sh /usr/share/apps/q4os_system/bin/qapt_fix.sh

Please see http://www.q4os.org/dqa011.html#system.1

Offline

#11 2016-11-13 18:00

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

Thanks q4osteam, but unfortunately that didn't solve the problem. I removed the version I installed from the Lazarus site and reinstalled from the depository, but running the VLC installer still results in the same error message.

Offline

#12 2016-11-13 18:09

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

You should remove each non-Debian/external package you have previously installed:
$ sudo dpkg -r --force-all <package-name>
$ sudo apt-get update

Next run the fix script:
$ sudo sh /usr/share/apps/q4os_system/bin/qapt_fix.sh
and put output here to analyze.

Offline

#13 2016-11-13 18:20

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

Could you post the result of sudo apt-get install vlc so we can see the exact errors for vlc, it should tell us which package is causing the problem.

Offline

#14 2016-11-13 19:06

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

I have just done a fresh installation to virtualbox and then installed vlc without issue, so it is not a reproducible error that can be easily traced. I would recommend a fresh install to be sure of a clean system, and then everything should install correctly.
Also it would probably be worth a post here before installing an untested deb file as someone might have pointed you towards the packages you originally wanted in the debian repos.

Offline

#15 2016-11-13 19:11

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

ok, I have (I think) removed the original packages downloaded from the lazarus site and also all other lazarus/fpc packages, then I ran the broken packages script followed by apt-get update and apt-get dist-upgrade (no problems reported). This is what I get when I try to install vlc:

sudo apt-get install vlc
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
vlc : Depends: libgles1-mesa (>= 7.8.1) but it is not going to be installed or
                libgles1
       Depends: libgles2-mesa (>= 7.8.1) but it is not going to be installed or
                libgles2
E: Unable to correct problems, you have held broken packages.

Offline

#16 2016-11-13 19:16

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

Yes I think a fresh install will be my best hope.

Offline

#17 2016-11-13 20:57

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

Yes, It is almost impossible to trace what the issue is if it cannot be replicated, not totally impossible but it does require quite a lot of trial and error testing to eliminate all other possible causes.

Offline

#18 2016-11-14 09:48

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

Ok, I've reinstalled q4os and all the software I need (apart from lazarus) including vlc. The problem is that the version of lazarus in the repos isn't up to date and I need the latest version. I had no problem with the debs from the lazarus site until there was an update, when it was removed and replaced with an older version. Other users have complained of the same problem with other debian distros like Ubuntu, see here:

http://forum.lazarus.freepascal.org/ind … 610.0.html

These users have said that to avoid the problem you should not allow these packages to be updated, so is there a way to remove specific packages for updating in q4os?

Here are my upgradable packages:

ffmpeg/stable 10:2.6.9-dmo1 i386 [upgradable from: 7:3.2-2~bpo8+2]
fpc/jessie-backports 3.0.0+dfsg-9~bpo8+1 i386 [upgradable from: 3.0.0]
libav-tools/stable 10:2.6.9-dmo1 all [upgradable from: 7:3.2-2~bpo8+2]

So I want to remove fpc from the upgradable list, since that's what is causing the problem.

Last edited by Jerome (2016-11-14 10:35)

Offline

#19 2016-11-14 19:59

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

Jerome wrote:

... so is there a way to remove specific packages for updating in q4os?

Yes it is, however we wouldn't recommend to do that, as you will block upgrading of these packages. If there will be some other packages, that depends on held packages, it could block upgrading of significant packages set.
If you still want to hold some packages versions you can do that this way:
$ sudo apt-mark hold package_name
To cancel holding:
$ sudo apt-mark unhold package_name
'hold' is used to mark a package as held back, which will prevent the package from being automatically installed, upgraded or removed.

The more powerful and more sophisticated alternative is to use APT pinning, please see https://wiki.debian.org/AptPreferences

Jerome wrote:

Here are my upgradable packages:
ffmpeg/stable 10:2.6.9-dmo1 i386 [upgradable from: 7:3.2-2~bpo8+2]
fpc/jessie-backports 3.0.0+dfsg-9~bpo8+1 i386 [upgradable from: 3.0.0]
libav-tools/stable 10:2.6.9-dmo1 all [upgradable from: 7:3.2-2~bpo8+2]

Which commands did you use to find out 'upgradable packages' ?

Offline

#20 2016-11-14 20:14

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

that looks like the result of apt list --upgradable.

One alternative is to use Scorpion (q4os testing version) as lazarus 1.6 is available there.

Offline

#21 2016-11-14 20:37

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

Dai_trying wrote:

One alternative is to use Scorpion (q4os testing version) as lazarus 1.6 is available there.

Yes, we would recommend to wait for the next Scorpion version, as Debian Stretch, the base for Scorpion, is approaching a frozen state and will be more stable soon. We guess the new Scorpion release will be available in a month.

Offline

#22 2016-11-14 20:41

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: Can't install VLC

q4osteam wrote:

We guess the new Scorpion release will be available in a month.

Waiting eagerly for that! smile

Offline

#23 2016-11-15 08:52

Jerome
Member
Registered: 2016-02-26
Posts: 125

Re: Can't install VLC

Thanks for the feedback. I'm also looking forward to the Scorpion release. As a matter of interest, what determines which packages are upgradable and which aren't? Is it because some packages are installed from backports and does this sometimes create conficts?

that looks like the result of apt list --upgradable.

Correct.

Last edited by Jerome (2016-11-15 08:53)

Offline

#24 2016-11-15 10:02

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,096
Website

Re: Can't install VLC

Jerome wrote:

As a matter of interest, what determines which packages are upgradable and which aren't? Is it because some packages are installed from backports and does this sometimes create conficts?

The main criteria is obviously the package version. Nonetheless, some 'upgradable' packages could be blocked by APT pinning, it's probably the case of packages you stated.

Offline

Board footer

Powered by FluxBB