You are not logged in.

#1 2016-09-21 18:30

ichbin1199
Member
From: France
Registered: 2016-02-09
Posts: 34

nvidia geforce 555gt driver issue on asus n75sf

Hi,

I have a big problem with my nvidia graphic card on my asus n75 laptop. When I install the nvidia driver ( i tried the 340 and even the 304 as it was told with the nvidia detect utility) but it does not work? Sometimes I just get a cli prompt: so I have to remove all nvidia package and the xorg.conf to get my gui back. Sometimes the gui load correctly but when i run nvidia-settings, I get this message:
"You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server."

I did not do it because I've already done it on my manjaro system (I have the same issue on it, and also on linuxmint/kde18): it went bad, I got a low resolution that I can't fix.

Is there any way to make it work and to access to the bumblebee graphic card switcher?

Thanx for help!


Samsung Q1 Ultra Premium umpc, (1.33ghz Intel core solo, 2gb ram)/Q4OS Scorpion/Trinity+Compaq  CQ2301 (1.6ghzx2 Intel Atom 230, 1gb ram, used as a server)/Q4OS Orion/Trinity+Packard bell D2317 (2.2ghzx2 Intel Pentium, 2gb ram)/Q4OS Scorpion/Trinity

Offline

#2 2016-09-22 07:18

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: nvidia geforce 555gt driver issue on asus n75sf

Did you try this one ? https://wiki.debian.org/Bumblebee

Offline

#3 2016-09-22 17:09

ichbin1199
Member
From: France
Registered: 2016-02-09
Posts: 34

Re: nvidia geforce 555gt driver issue on asus n75sf

q4osteam wrote:

Did you try this one ? https://wiki.debian.org/Bumblebee

Hi q4os team!

Thank you for you help.

That's what I tried first, and I did retry it, but unfortunately it does not work.


Samsung Q1 Ultra Premium umpc, (1.33ghz Intel core solo, 2gb ram)/Q4OS Scorpion/Trinity+Compaq  CQ2301 (1.6ghzx2 Intel Atom 230, 1gb ram, used as a server)/Q4OS Orion/Trinity+Packard bell D2317 (2.2ghzx2 Intel Pentium, 2gb ram)/Q4OS Scorpion/Trinity

Offline

#4 2016-09-22 17:57

ichbin1199
Member
From: France
Registered: 2016-02-09
Posts: 34

Re: nvidia geforce 555gt driver issue on asus n75sf

I have re-installed driver following this:
https://wiki.debian.org/NvidiaGraphicsDrivers
and still the same. Nvidia-settings still tells me: You do not appear to be using the NVIDIA X driver.  Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. (not doing it because it breaks my system).

There is a back up of an xorg.conf file in /etc/X11. When I use it again, I boot the the cli prompt only (no x server). When I remove that file, X works again. So maybe that issue is related to xorg.conf?


Samsung Q1 Ultra Premium umpc, (1.33ghz Intel core solo, 2gb ram)/Q4OS Scorpion/Trinity+Compaq  CQ2301 (1.6ghzx2 Intel Atom 230, 1gb ram, used as a server)/Q4OS Orion/Trinity+Packard bell D2317 (2.2ghzx2 Intel Pentium, 2gb ram)/Q4OS Scorpion/Trinity

Offline

#5 2016-09-22 18:10

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: nvidia geforce 555gt driver issue on asus n75sf

You should generate new xorg.conf using 'sudo nvidia-xconfig' command. You could edit generated xorg.conf and try to set some options to get a particular NVIDIA card to work, please see http://us.download.nvidia.com/XFree86/L … dix-b.html

If you remove xorg.conf, the default nouveau driver is used instead of nvidia, so the X server comes up.

Offline

#6 2016-09-22 18:58

ichbin1199
Member
From: France
Registered: 2016-02-09
Posts: 34

Re: nvidia geforce 555gt driver issue on asus n75sf

q4osteam wrote:

You should generate new xorg.conf using 'sudo nvidia-xconfig' command. You could edit generated xorg.conf and try to set some options to get a particular NVIDIA card to work, please see http://us.download.nvidia.com/XFree86/L … dix-b.html

If you remove xorg.conf, the default nouveau driver is used instead of nvidia, so the X server comes up.

Here's some news: in fact the nvidia driver was used (without xorg.conf; when there is a xorg.conf, especially the one generated by nvidia-xconfig, I have non x server) even if nvidia-settings, launched from gui or with simple nvidia-settings command, tells the contrary.

As a matter of fact, when I type that command (found on a manjaro forum): optirun -b none nvidia-settings -c :8 , the nvidia settings program shows now a working nvidia gpu. Nethertheless, I still can't switch to the intel card in order to save some battery life. In order to be sure, I have removed nouveau (
sudo apt-get remove xserver-xorg-video-nouveau) without any issue.

Now I have to figure out how to activate bumblebee

Last edited by ichbin1199 (2016-09-22 18:59)


Samsung Q1 Ultra Premium umpc, (1.33ghz Intel core solo, 2gb ram)/Q4OS Scorpion/Trinity+Compaq  CQ2301 (1.6ghzx2 Intel Atom 230, 1gb ram, used as a server)/Q4OS Orion/Trinity+Packard bell D2317 (2.2ghzx2 Intel Pentium, 2gb ram)/Q4OS Scorpion/Trinity

Offline

#7 2016-09-22 19:08

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: nvidia geforce 555gt driver issue on asus n75sf

You can check the current video driver in use from /var/log/Xorg.0.log

Offline

#8 2016-09-22 19:42

ichbin1199
Member
From: France
Registered: 2016-02-09
Posts: 34

Re: nvidia geforce 555gt driver issue on asus n75sf

...

Last edited by ichbin1199 (2016-09-24 21:06)


Samsung Q1 Ultra Premium umpc, (1.33ghz Intel core solo, 2gb ram)/Q4OS Scorpion/Trinity+Compaq  CQ2301 (1.6ghzx2 Intel Atom 230, 1gb ram, used as a server)/Q4OS Orion/Trinity+Packard bell D2317 (2.2ghzx2 Intel Pentium, 2gb ram)/Q4OS Scorpion/Trinity

Offline

Board footer

Powered by FluxBB