You are not logged in.

#1 2016-09-19 09:52

Jerome
Member
Registered: 2016-02-26
Posts: 148

Outdated avconv

Sometimes I download TV programs from bbciplayer using youtube-dl, which although available in the repositories, doesn't work (you have to download the newer version from the youtube-dl site. https://rg3.github.io/youtube-dl/download.html).

However when playing back the mpeg-4 files the audio and video are out of sync. When starting to download a file, youtube-dl gives me this message:

WARNING: Your copy of avconv is outdated and unable to properly mux separate video and audio files, youtube-dl will download single file media. Update avconv to version 10-0 or newer to fix this.

avconv is part of the package libav-tools but I already have the newest version of this, so not sure how to fix the problem. Any help appreciated.

Last edited by Jerome (2016-09-19 09:53)

Offline

#2 2016-09-19 10:45

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,320

Re: Outdated avconv

Is that the backports version of libav-tools that you've got?

Other possibility would be to cobble together a working get-iplayer using these instructions -
https://squarepenguin.co.uk/downloads/debian/

Good luck

Offline

#3 2016-09-19 16:07

Jerome
Member
Registered: 2016-02-26
Posts: 148

Re: Outdated avconv

Hi bin,

Backports version? Excuse my ignorance but what does that mean?

Offline

#4 2016-09-19 16:20

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,320

Re: Outdated avconv

Backports are later packages from the upstream (less stable by comparison) debian system.
They are compiled to work with the current Jessie version.
This may help explain more
https://backports.debian.org/Instructions/

Backports are enabled via Synaptic>Repositories - you'll see a line showing jessie-backports in the distribution column.

To install the libav-tools you would do:-
sudo apt-get -t jessie-backports install libav-tools

However, having just done that it reports the installed version is the latest so that's a dead end :-)

Do you use VLC to play the downloaded files?

Offline

#5 2016-09-19 18:31

Jerome
Member
Registered: 2016-02-26
Posts: 148

Re: Outdated avconv

Thanks for the info which will useful for future reference.

Do you use VLC to play the downloaded files?

No I put them onto a USB stick which I then plug into my TV.

Offline

Board footer

Powered by FluxBB