You are not logged in.

#1 2024-04-21 16:25

FlexQ4
Member
Registered: 2017-02-19
Posts: 153

Eclipse installation: Archive Error

Hi,
i wanted to install the Eclipse/Java IDE 4.25, downloaded from here: https://www.eclipse.org/downloads/packa … /2022-09/r the x86_64 tar.gz (link: https://www.eclipse.org/downloads/downl … 64.tar.gz) but it's not possible to open this archive with ark: "An error occured while trying to open the archive".
Can anyone here confirm this or help?
Thank you!

Offline

#2 2024-04-21 20:15

hchiper
Member
From: Belgium
Registered: 2020-07-28
Posts: 410

Re: Eclipse installation: Archive Error

Your download link does not work. I get this error message:

Eclipse downloads - file unavailable
The selected file is invalid, or it is no longer available for download.
This happens when the file is part of a nightly or development build. If so, please return to the project's home page and download a newer version.

Another point is that the Eclipse .tar.gz files are big ones... maybe ark has problems due to that. Try to use the tar (in a terminal).


Q4OS machines: [Samsung R519 - Pentium T4200 2.0 GHz - 4 GB RAM - 500 GB SSD] & [Sony Vaio - Pentium P6000 1.87 GHz - 8 GB RAM - 500 GB SSD]

Offline

#3 2024-04-22 06:32

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,305

Re: Eclipse installation: Archive Error

I'd suggest you install engrampa - it's a much better tool than ark.
Alternatively investigate how to extract a .tar.gz archive via CLI/Konsole.

Offline

#4 2024-04-22 16:34

FlexQ4
Member
Registered: 2017-02-19
Posts: 153

Re: Eclipse installation: Archive Error

hchiper wrote:

Your download link does not work. I get this error message:
Eclipse downloads - file unavailable
The selected file is invalid, or it is no longer available for download.

bin wrote:

investigate how to extract a .tar.gz archive via CLI/Konsole.

Thanks men,
the direct link (in panthesis) was ment for identification purpose only - no idea why dl works only directly from the site.
i achieved to unpack the .tar.bz in 2 steps using bunzip and then tar.
Now i wonder if it contains yet a java compolier or if i have to install that seperately wink

Edit: yes, java is integrated. However, many warnings at startup like

(Eclipse:2593): Gtk-WARNING **: 17:44:46.181: Theme parsing error: gtk-widgets.css:1357:25: The style property GtkRange:slider-width is deprecated and shouldn't be used anymore. It will be removed in a future version

(Eclipse:2593): Gtk-WARNING **: 17:44:46.181: Theme parsing error: gtk-widgets.css:1358:25: The style property GtkRange:stepper-size is deprecated and shouldn't be used anymore. It will be removed in a future version

(Eclipse:2593): Gtk-WARNING **: 17:44:46.181: Theme parsing error: gtk-widgets.css:1359:34: The style property GtkScrollbar:min-slider-length is deprecated and shouldn't be used anymore. It will be removed in a future version

(Eclipse:2593): Gtk-WARNING **: 17:44:46.181: Theme parsing error: gtk-widgets.css:1360:28: The style property GtkRange:stepper-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

(Eclipse:2593): Gtk-WARNING **: 17:44:46.181: Theme parsing error: gtk-widgets.css:1361:34: The style property GtkRange:trough-under-steppers is deprecated and shouldn't be used anymore. It will be removed in a future version

Last edited by FlexQ4 (2024-04-22 16:47)

Offline

#5 2024-04-22 20:59

FlexQ4
Member
Registered: 2017-02-19
Posts: 153

Re: Eclipse installation: Archive Error

Does anyone here utilize eclipse for java or c(++) development?
I had the idea (to try) to investigate (and maybe fix) some issues i found in konqueror.
Is that approach feasible with eclipse ide?

Offline

#6 2024-04-23 07:42

hchiper
Member
From: Belgium
Registered: 2020-07-28
Posts: 410

Re: Eclipse installation: Archive Error

FlexQ4 wrote:

Edit: yes, java is integrated. However, many warnings at startup like

Probably because you are using and old version (2022-09). You can find an up to date version (2024-03) on this page (installer + packages).
No idea for your other questions.


Q4OS machines: [Samsung R519 - Pentium T4200 2.0 GHz - 4 GB RAM - 500 GB SSD] & [Sony Vaio - Pentium P6000 1.87 GHz - 8 GB RAM - 500 GB SSD]

Offline

Board footer

Powered by FluxBB