You are not logged in.

#1 2022-11-22 22:59

Becks1921
Member
Registered: 2022-11-22
Posts: 4

Laptop doesn't shutdown

So, for a while, after turning my screensaver off, my laptop (Lenovo Yoga 2) doesn't turn off. Each time I attempt to do the previous, it shuts off for a few seconds, then it reboots.

I have installed system d, then it turns off properly. For context, I have recently installed several Desktop Environments and I have an updated kernel. The computer worked well for a brief moment. The previous issue arises when I switch Desktop Environment and/or when I update each of them.

Should I only use Trinity, and remove the other Desktop Environments? Mate seems to be working better on my laptop. Lastly, what are the default/recommended settings for tdepower?

I look forward to a fix. Thank you very much.

Offline

#2 2022-11-23 07:19

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,200

Re: Laptop doesn't shutdown

Becks1921 wrote:

I have installed system d, then it turns off properly.

Q4OS is based on Debian Bullseye and by default runs on systemd.

Please confirm what you actually installed as the starting point for all this.

Offline

#3 2022-11-29 03:13

Becks1921
Member
Registered: 2022-11-22
Posts: 4

Re: Laptop doesn't shutdown

I apologize for the delay. The following are installed:
1) LXDE
2) System X11 Default
3) Default Xsession
4) LXQt Desktop
5) MATE (the snappiest for my laptop)
6) Openbox
7) TDE
8) Xfce session

Kernel: 5.19.0-0.deb11.2-amd64

Offline

#4 2022-11-29 07:17

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,200

Re: Laptop doesn't shutdown

Please open a terminal or Konsole depending on your current DE  and enter inxi -F

Copy and paste the out put here please.

When you want to shut down, open terminal and type

sudo shutdown -h 0

   that's a zero at the end.

Does that shutdown and stay down?

Offline

#5 2022-11-29 08:29

Becks1921
Member
Registered: 2022-11-22
Posts: 4

Re: Laptop doesn't shutdown

System:
  Host: q4os-desktop Kernel: 5.19.0-0.deb11.2-amd64 x86_64 bits: 64
  Desktop: MATE 1.24.1 Distro: Q4OS 4.10.2-n1
Machine:
  Type: Laptop System: LENOVO product: 20332 v: Lenovo Yoga 2 11
  serial: <superuser required>
  Mobo: LENOVO model: AIUU1 v: 31900049WIN serial: <superuser required>
  UEFI: LENOVO v: 92CN93WW(V1.93) date: 08/19/2015
Battery:
  ID-1: BAT0 charge: 18.1 Wh condition: 31.8/32.7 Wh (97%)
CPU:
  Info: Quad Core model: Intel Pentium N3540 bits: 64 type: MCP
  L2 cache: 1024 KiB
  Speed: 749 MHz min/max: 500/2666 MHz Core speeds (MHz): 1: 583 2: 583
  3: 636 4: 557
Graphics:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series Graphics & Display
  driver: i915 v: kernel
  Device-2: Sunplus Innovation Lenovo EasyCamera type: USB driver: uvcvideo
  Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting
  unloaded: fbdev,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics (BYT) v: 4.2 Mesa 20.3.5
Audio:
  Device-1: Intel Atom Processor Z36xxx/Z37xxx Series High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k5.19.0-0.deb11.2-amd64
Network:
  Device-1: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
  driver: ath9k
  IF: wlp1s0 state: up mac: d0:53:49:f6:9c:29
  Device-2: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
Bluetooth:
  Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
  Report: ID: hci0 state: up running bt-v: 2.1 address: D0:53:49:F6:EA:49
Drives:
  Local Storage: total: 465.76 GiB used: 21.55 GiB (4.6%)
  ID-1: /dev/sda vendor: Western Digital model: WD5000MPCK-24AWHT0
  size: 465.76 GiB
Partition:
  ID-1: / size: 455.95 GiB used: 21.52 GiB (4.7%) fs: ext4 dev: /dev/sda2
  ID-2: /boot/efi size: 511 MiB used: 3.4 MiB (0.7%) fs: vfat dev: /dev/sda1
Swap:
  ID-1: swap-1 type: partition size: 976 MiB used: 28.2 MiB (2.9%)
  dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 245 Uptime: 10m Memory: 3.72 GiB used: 2.5 GiB (67.2%)
  Shell: Bash inxi: 3.3.01


And the computer shut down for a few seconds then rebooted after executing the above command.

Offline

#6 2022-11-29 13:52

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,200

Re: Laptop doesn't shutdown

Hmmmm OK.

Trying to sort this type of problem with so many bits and bobs installed is a nightmare. If this were my machine I would first of all back up any personal stuff then wipe and start again. Install Trinity and just the stock kernel.

See how it behaves. If it's still messing try the backports kernel - you'll find the instructions https://www.q4os.org/dqa011.html#system.6 - you have to enable backports in your repos.

I've a vague memory that will also pull in the newer firmware packages.

Please report progress.

Offline

#7 2022-11-29 16:04

Becks1921
Member
Registered: 2022-11-22
Posts: 4

Re: Laptop doesn't shutdown

Thank you very much! Will do ?

Offline

Board footer

Powered by FluxBB