You are not logged in.

#1 2022-01-04 01:54

Registered: 2022-01-04
Posts: 1

Menu entries created within kmenuedit are not xdg-valid

I really tried to create a new topic in the right section (bug tracking) but I wasn't able to, so I'm posting it here (not knowing the exact appropriate place to).

I was using kmenuedit (TDE Menu Editor) to manage my applications in the main menu, but then I noticed my Ungoogled Chromium custom installed hadn't been setted as my default browser (specially in gtk applications like Zotero or Chromium itself), even after trying to use xdg-mime commands or with TDE Control Panel. Then I noticed, after a update-desktop-database ~/.local/share/applications/ command, that all the entries that I created in kmenuedit are not being readed as valid ones. The apparent reason is those "[$e]" after Exec and Path parameters within .desktop files, as you all can notice below:


After manually editing the Chromium .desktop entry (and that's why it is not appearing in this capture), I was perfectly able to set Ungoogled Chromium as my default browser, recognized even by gtk application like Zotero.

Thanks in advance.
While it's not solved, I'll be using menulibre package as a non-TDE alternative hmm

EDIT by Admin:
This bug has been registered in the official bug tracker


Board footer

Powered by FluxBB