You are not logged in.

#1 2021-01-13 10:27

globetrotterdk
Member
Registered: 2020-12-23
Posts: 31

(Solved) KDE Plasma. Installer disallows custom mount points.

I tried to install q4os-3.13-x64.r1 on a new laptop yesterday. Besides the problem with having to manually load nvidia-driver as there is no ncurses installer, the installer disallowed my custom mount point. My laptop has both a 500 GB SSD and 1 TB HDD, so on the SSD, I created a root and a home partition, while on the HDD I created a swap and a data partition. Swap was no problem, but setting the mount point for the last partition as /data was not accepted. Am I missing something, or is that just the way the installer rolls at this time?

I really like Q4OS and much prefer it to other Debian based distributions such as MXLinux, but it sometimes is more difficult than other distros to install on modern hardware.

----

I seem to remember that it is possible to edit some file manually, to get the UUID for the /data partition to mount automatically at boot, but I can't remember any details about how to do this. Can anyone help out? Thanks in advance.

Last edited by globetrotterdk (Yesterday 09:11)


I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

#2 2021-01-13 13:32

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,931
Website

Re: (Solved) KDE Plasma. Installer disallows custom mount points.

What installation iso media did you use ?

Offline

#3 2021-01-13 15:30

globetrotterdk
Member
Registered: 2020-12-23
Posts: 31

Re: (Solved) KDE Plasma. Installer disallows custom mount points.

q4osteam wrote:

What installation iso media did you use ?

q4os-3.13-x64.r1.iso written to USB stick.

----

Did some research and it is the /etc/fstab file that needs to be modified. For a /data partition, I added the following
UUID=<UUID of my HDD with /dev/sda2> /data                   ext4    defaults,noatime        1 2

That I couldn't set the mount point when I installed Q4OS is one issue that can be improved on. However, editing an /etc/fstab is probably never going to be glossed over by "making it look more like Windows", as the processes are not the same. However, it is possible to make some of these things more user friendly for people not familiar with Linux. Using resources on making Q4OS look more like Windows, is a waste of resources in my opinion, that can be better spent on making Q4OS more user friendly and business oriented.

----

Unfortunately, the /data partition does not mount for me as user. I tried adding "user" to the above line in the /etc/fstab, but when I rebooted I ended up in emergency mode and had to remove "user" again from the line in /etc/fstab. How can I get the partition to mount at boot for me as user?

Last edited by globetrotterdk (2021-01-14 16:45)


I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

#4 2021-01-15 00:16

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,931
Website

Re: (Solved) KDE Plasma. Installer disallows custom mount points.

globetrotterdk wrote:

How can I get the partition to mount at boot for me as user?

Systemd can't mount a device as a user at boot sequence. You likely need to set the "uid=" and "gid=" options, see:
$ man mount

Offline

#5 2021-01-15 10:28

globetrotterdk
Member
Registered: 2020-12-23
Posts: 31

Re: (Solved) KDE Plasma. Installer disallows custom mount points.

q4osteam wrote:
globetrotterdk wrote:

How can I get the partition to mount at boot for me as user?

Systemd can't mount a device as a user at boot sequence. You likely need to set the "uid=" and "gid=" options, see:
$ man mount

Thanks. I didn't really understand much of the man page, so I tried using Gnome Disks, by which it is possible to set the parameters for /etc/fstab for the partition by choosing "edit mount options" and then afterwards ran

sudo chmod ugo+wx /media/<name>

This didn't work either...

OK, the values listed in Gnome Disks for /etc/fstab are as follows:

gid=XXXX,nosuid,nodev,nofail,x-gvfs-show,x-gvfs-name=Data

where gid equals the value from:

$ id -g <user name>

Unfortunately, still no change. The partition is still owned by root.

----

I looked in the logs and found the following:

Failed to mount /media/XXXXXXXXXXXXXXX.
jan 15 15:09:33 computer kernel: EXT4-fs (sda2): Unrecognized mount option "gid=xxxx" or missing value

Again, not sure what to do with this.

Last edited by globetrotterdk (2021-01-15 14:18)


I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

#6 Yesterday 09:10

globetrotterdk
Member
Registered: 2020-12-23
Posts: 31

Re: (Solved) KDE Plasma. Installer disallows custom mount points.

OK, I sorted this out with some help on Facebook. As this topic is rather complex, I have tried to systematize what I did in a How To in the forum. The post is located here: https://www.q4os.org/forum/viewtopic.ph … 418#p19418


I’ve had a perfectly wonderful evening, but this wasn’t it. - Groucho Marx

Offline

Board footer

Powered by FluxBB