You are not logged in.

#1 2020-02-24 02:52

gurdonark
Member
Registered: 2016-01-08
Posts: 22

SOLVED: Keyboard lag in Trinity DE

My Q4OS system run into a new issue this evening. I am running the version based on Debian 9.12, which I believe is termed Scorpion. I was using the system with the Trinity DE easily just as I usually do. All of a sudden, my keyboard developed extreme lag. A keypunch might take seconds to register, or require a particularly firm keypunch.

I logged out. One of the things I tried (after using high-pressure air to clean my keyboard) was to log back in using the Cinnamon DE.
Now I am typing this on a normally functioning keyboard again in Q4Os using the Cinnamon DE.

I ask for suggestions about what I might try to try to get my keyboard working again on Trinity. I like Cinnamon, but good old Trinity appeals to me more.   Thank you, in advance, for any assistance.

Last edited by gurdonark (2020-03-26 04:58)

Offline

#2 2020-02-25 08:11

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,643
Website

Re: SOLVED: Keyboard lag in Trinity DE

You could check, if keyboard works under a new test user account. It would show at least, if the problem lies in the user, or system configuration.

Offline

#3 2020-02-29 23:29

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

Thank you for the suggestion. So far, when i created the user account, I am getting an error message when I try to log into TDE.
But I want to try again and come back before I follow up with another question. I can access my system from Cinnamon or LXDE, but
so far have the keyboard issue on TDE.  The system works fine on LXDE, though on LXDE and Cinnamon I cannot mount a USB drive but instead get the error warning that I do not have the authority (though my user has all the admin boxes checked).

I will try again to log in as a new user, and then check back.

Offline

#4 2020-02-29 23:39

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

Update:

I successfully logged in as a different user. The new user has good keyboard function, without lag. This suggests to me that my personal user has a setting issue.  But the keyboard settings I see do not seem to alleviate the issue.

I also have this new issue, of lacking authority in my personal user to mount a USB. The new user can mount a USB. So I am uncertain why my user, whose user ID has all the permission boxes checked, cannot mount a USB.

If all else fails, I can create a new personal user and be close to normal. But I prefer to fix my current userID.

Thank you, in advance, for any ideas on this.  I am grateful.

Offline

#5 2020-03-03 10:07

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,643
Website

Re: SOLVED: Keyboard lag in Trinity DE

Unfortunately we have no idea what configuration option led to the keyboard lag. Anyway, you could try to reset all desktop settings for the first user, please see:
https://www.q4os.org/dqa011.html#desktop.7
Note, it will reset all the desktop settings, so you will need to set them up again.

Offline

#6 2020-03-17 05:10

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

Thank you for your suggestion to redo the desktop settings. I succeeded in running this command, and reset the desktop settings. Unfortunately, that did not solve the keyboard issue.

Perhaps another tack is in order. What command would I use to first:
a. remove the Trinity desktop without damaging essential things for Q4OS and then
what command would I use to:
b. reinstall the Trinity desktop again.

I still can run fine in LXDE, Cinnamon, etc. (and figured out how to ensure I could mount USB and SD media).
But whatever I did to create that keyboard lag in Trinity DE, I seem to have done it too well.

Thanks for your help on  this.

Last edited by gurdonark (2020-03-17 05:11)

Offline

#7 2020-03-17 06:56

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 731

Re: SOLVED: Keyboard lag in Trinity DE

Do you by any chance have multiple languages installed - if so do you also have the keyboard switching icon in the system tray?

Offline

#8 2020-03-26 04:58

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

Thanks for asking. I only have one language installed.

Offline

#9 2020-03-26 05:12

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

I finally figured out what caused my keyboard lag. I found that the accessibility setting for the keyboard created this delay. i changed this, and now my desktop environment works as usual.

Offline

#10 2020-03-26 09:48

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,643
Website

Re: SOLVED: Keyboard lag in Trinity DE

Thanks for the info. If you are able to reproduce the issue, you could report it for Trinity developers https://mirror.git.trinitydesktop.org/g … lore/repos , alternatively you are also welcome to put a procedure to reproduce it here.

Offline

#11 2020-03-26 18:26

gurdonark
Member
Registered: 2016-01-08
Posts: 22

Re: SOLVED: Keyboard lag in Trinity DE

Thank you. Here's a better attempt to describe the solution I reached. After reading up on keyboard delays, and accessibility controls from the command line, I decided to use the GUI to try to modify the keyboard delay.  My initial, failed attempt simply went to Trinity Control Center, then to Peripherals, and then to keyboard. But adjusting those settings did not solve the problem, nor did re-setting to default.

The thing that solved the problem was going to Trinity Control Center, then to Regional and Accessibility, and then to keyboard, and then adjusting the delay there.

The way I created the problem still is a mystery to me. I assume that I must have inadvertently hit a key that triggered an accesibility delay, but I cannot duplicate that step.

Last edited by gurdonark (2020-03-26 18:29)

Offline

#12 2020-03-26 18:31

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,643
Website

Re: SOLVED: Keyboard lag in Trinity DE

Thanks for the explanation, we will try to figure out which way to trigger the issue.

Offline

Board footer

Powered by FluxBB