You are not logged in.

#1 2019-01-26 19:17

Aeterna
Member
Registered: 2019-01-26
Posts: 1

Screen Tearing on Intel iGPU

I've been using Q4OS for a couple of months now. A recent update did something where I began to see really bad artifacting on my screen when scrolling in Chromium or watching YouTube videos. I found a simple fix for it though. All you need to do is make an Xorg configuration file.

Start by opening Konsole and getting administrator access with "sudo su" and type your user's password. Then "cd /etc/X11/xorg.conf.d" and then "nano 20-intel.conf" which opens the nano text editor in the terminal. Then paste the following:

Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option "TearFree" "true"
EndSection

Then "Ctrl+O" to save and "Ctrl+X" to exit. Close Konsole, log out your user, and then click the menu button and choose "Restart X Server". That should apply the setting but if not just restart the whole PC. And that's it. All screen tearing should be gone. This worked for me on a GMA 4500 iGPU

Offline

#2 2019-01-26 21:59

sickpig
Member
Registered: 2019-01-08
Posts: 39

Re: Screen Tearing on Intel iGPU

thats a great tip
thanks for sharing

the other option which works better for my machine(could be specific to my i5 processor) is using openbox as a WM without any compositing

if i do that then i get tear free videos without adding any extra conf file

also in comparison i found the video playback to be smoother in openbox

again could be specific to my machine

great tip nevertheless, should help other users

Last edited by sickpig (2019-01-26 21:59)

Offline

Board footer

Powered by FluxBB