You are not logged in.

#1 2016-08-30 21:27

olzeke51
Member
From: So. Carolina, USA
Registered: 2016-08-24
Posts: 22

Dev Pack 1.61 Orion - missing doc

Hi All,         (MOVED FROM Scorpion Dev post started by Dai)
This is not for Scorpion - but it does involve the/a developer pak.....
New to developing - downloaded an    '.esh' file [not for Scoripion AFAIK]
Installed a gazillion files on my system FWIW-[install CD - classic(minimal)-1.6.1----edited - removed erroneous data- olzeke51]
launched the Develop app from the menu
looking through the 'Docuuments' tab on the right side of the screen, down to the TDevelop API Do.../Planned tasks/High priority
and got this message :
"The file or folder /opt/trinity/share/doc/tde/HTML/en/tdevelop-apidocs/doc/api/html/HighPriTasks.html does not exist."
the api folder only has a classmap.inc  in it !!!  - no 'html folder
a Find on 'HighPriTasks.html' found nothing -- the error would indicate it is not on the 'trinity website' [I noticed some of the other 'documents' were url links]
'
Issue #2 - how do I originate a Post on the forum???
'
Thanks - Gary Olzeke51

DAI's RESPONSE:

Dai_trying wrote:

Hi Gary, To create a new post in the forum just select the category you want and then click the "post new topic" at the top of the page smile
I can't really make much sense of what you have done, that is I cannot say what you have installed so it would be very difficult to say what the actual problem is or what the solution would be...
if you want to create a fresh topic please state the version of Q4OS you are using

get-q4os-version

and we would need to know what package you installed and/or where it came from. If it is a .esh installer then it is likely to have been created for q4os as I don't know any other OS that uses them (although I don't use ALL linux distro's so could be wrong).

OLZEKE'S FOLLOWUP POST:


Hi Dai,
get-q4os-version = 1.6.1-n1  -- from the install disk (not live)
from the developer section of the website I downloaded this:
setup_q4os-devpack_2.2.2-a1_all.esh
installed okay AFAIK - I just scanned the install details -- no errors
[see attached file - 221K big]  TOO BIG to attach
BTW- it looks like devs are using qt5 or a portion of it!!!
'
?? anyone know why -- ? ; is Trinity going to qt5?, or did q4os team decide to??
'
I d/l'd the dev pack so I could wrap my head around Q4OS on Trinity on QT3/4? on X11.
I was going to look into some quirks I noticed, but didn't want to 'bug' them till I found a hint.
'
one quirk -- if I right click an html file (saved by firefox) and select 'open with' and traverse
Programs/Accessories/Internet and select Konqueror -- I have to respond to a TDESudo popup!!
I'm looking into it - slowly --( I have discovered that the TDESudo is required again after 30 min of no activity)
No need to worry about this
'
Thanks y'all  - [southern USA talk!!]
Gary
* * * * * * * *
this is for the application titled --TDevelop  but shows up as  menu item   "KDevelop Q4OS" under Programs/Q4OS Development Pack

Last edited by olzeke51 (2016-08-30 21:28)


The journey is . . . the reward.

Offline

#2 2016-08-30 22:03

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,375
Website

Re: Dev Pack 1.61 Orion - missing doc

olzeke51 wrote:

one quirk -- if I right click an html file (saved by firefox) and select 'open with' and traverse
Programs/Accessories/Internet and select Konqueror -- I have to respond to a TDESudo popup!!
I'm looking into it - slowly --( I have discovered that the TDESudo is required again after 30 min of no activity)
No need to worry about this

If you just open Konqueror and then navigate to the file and double click it you don't need to worry about sudo.

As for using Qt5, I think the devs are looking at it but they would need to comment about their intentions for it. smile

As for docs, have you checked the website to see if there is anything to help there?

Offline

#3 2016-08-31 00:45

olzeke51
Member
From: So. Carolina, USA
Registered: 2016-08-24
Posts: 22

Re: Dev Pack 1.61 Orion - missing doc

I checked the document section you linked to,  There is nothing obvious for
'TDevelope API documentation
'The TDE API Reference           topics that are listed in the
Kdevelop Q4OS application - Documents tab on the right side of the main window.
'
I did do a 'Find' file search that one of the above links referred to, but it (document or folder!) wasn't on the system
I did a Synaptic search for both Txxxx API with nothing conclusive.
'
'
double-click  --- man, do I feel stupid !!! -
oh, now I know -- FireFox is the default application for .html files (now)
but I also wanted to check out Konqueror's display of the same page so I had to select it from the menu tree.(it isn't rendered the same)


The journey is . . . the reward.

Offline

#4 2016-08-31 08:06

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,375
Website

Re: Dev Pack 1.61 Orion - missing doc

If you browse to the file using konqueror and double-click it the default action is to open it in konqueror. As for documentation for the TDE API, I'm afraid that is maybe beyond me but you could try the TDE website. that may have something useful for you.
Also have you checked the "TDevelop Assistant - Documentation Viewer"?

Offline

#5 2016-08-31 10:24

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,941
Website

Re: Dev Pack 1.61 Orion - missing doc

Trinity API - https://www.trinitydesktop.org/docs/trinity/index.html


Dai_trying wrote:

As for using Qt5, I think the devs are looking at it but they would need to comment about their intentions for it.

Q4OS distro is QT centric, we want to allow developers to use all TQT/QT4/QT5 libraries. So the DevPack installs TQT/QT4/QT5 development packages as well as QT Creator to allow QT4/5 coding. We suppose we will support LXQT desktop environment alongside TDE in the future, as soon as it will be more stable.

Offline

#6 2016-08-31 14:52

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,375
Website

Re: Dev Pack 1.61 Orion - missing doc

Q4OS Team wrote:

We suppose we will support LXQT desktop environment alongside TDE in the future, as soon as it will be more stable.

That's really good news to me! I do like LXQT even with it's rough edges at the moment. smile

Offline

Board footer

Powered by FluxBB