You are not logged in.

#1 2023-08-16 15:44

Rademes
Member
From: Latvia
Registered: 2015-12-13
Posts: 637

[Upstream] Left Win key in keyboard shortcuts.

Good day!
My system information is here: https://www.q4os.org/forum/viewtopic.ph … 004#p25004

When I go to settings:/Accessibility/ ---> Keyboard shortcuts and try to set Left Win key as a keyboard shortcut to any action, the program shows this key as ISO_Next_Group key. But why? It should be Win key.

Last edited by Rademes (2023-09-18 18:28)


Before asking for help please read this topic: https://www.q4os.org/forum/viewtopic.php?id=3502   If you have problems with WiFi network, try to install the Network Manager using Q4OS Software Centre.

Offline

#2 2023-09-16 13:13

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: [Upstream] Left Win key in keyboard shortcuts.

Added to the official bug tracker https://sourceforge.net/p/q4os/tickets/209/

We have investigated this issue, but we were not able to reproduce it on Q4OS nor Debian12/Trinity-14.1.1 so far. Clean installation of q4os-5.2-x64-tde.r2.iso on Acer Aspire 3. Configuring keyboard shortcuts as suggested by the OP displays keyboard shortcut properly as "Win+Space". We will investigate more and post back as any new info becomes available.
qg0056.png

Last edited by q4osteam (2023-09-17 12:54)

Offline

#3 2023-09-17 17:07

Rademes
Member
From: Latvia
Registered: 2015-12-13
Posts: 637

Re: [Upstream] Left Win key in keyboard shortcuts.

I have made some research.
First, let me show my keyboard layout switch settings, because that will be useful in the future:
https://drive.google.com/file/d/1ZmNRHm … sp=sharing
https://drive.google.com/file/d/1j8ePX5 … sp=sharing
As you can see, in my keyboard configuration I use Left Win key as a key to switch keyboard layouts, because it is very convenient so switch layouts in such way, you need to press only one button instead of two. That is the difference between my system and your test systems, because in clean install Left Win key is not assigned as a keyboard layout switch key.
Using this configuration I tried to reproduce this bug again, and yes, it is reproducible. Left Win Key is being assigned as ISO_Next_Group. But there is one interesting thing. When I deselect "Use Win key as modifier" and select it again, the bug disappears!
Please watch video at 720p:
https://drive.google.com/file/d/1Crxt9e … sp=sharing
But, after that, I am unable to use Left Win as a key to switch keyboard layouts.
Then, after reboot, everything reverts back. After reboot I can use Left Win key for switching keyboard layouts, and in Settings, Left Win Key again is being assigned as ISO_Next_Group.
Then I started to think, that maybe this bug is somehow connected with my keyboard layout switch settings?
So, I have removed LeftWin key as my keyboard layout switch key in Keyboard layout settings. Only Alt+Space was left to switch keyboard layouts. And after that and reboot this bug disappeared! LeftWin key is now being assigned as Win.
Please watch video at 720p:
https://drive.google.com/file/d/1XfQTMp … sp=sharing
So my conclusion is: The LeftWin key is being assigned as ISO_Next_Group key, if you have assigned it as keyboard layout switch key in Keyboard Layout setting tool.
If you have not assigned LeftWin key as keyboard layout switch key, this bug will not be reproducible.
Solution, how to avoid this bug, and still use LeftWin key as keyboard layout switch key:
1. Do not assign LeftWin key in Keyboard Layout setting tool.
2. Open in text editor (Kwrite, Kate) file /home/username/.trinity/share/config/kdeglobals
3. Change two strings. They should be following:
Popup Launch Menu=Ctrl+Escape
Switch to Next Keyboard Layout=Alt+Space;Super_L

4. Reboot the computer.
After reboot you will be able to use LeftWin key as keyboard layout switch key, and you will be able to assign it as Win+ key.

Update: Maybe Xkb (X11) asigns LeftWin key as ISO_Next_Group key?

Last edited by Rademes (2023-09-17 17:45)


Before asking for help please read this topic: https://www.q4os.org/forum/viewtopic.php?id=3502   If you have problems with WiFi network, try to install the Network Manager using Q4OS Software Centre.

Offline

#4 2023-09-17 22:11

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,351
Website

Re: [Upstream] Left Win key in keyboard shortcuts.

Rademes wrote:

So my conclusion is: The LeftWin key is being assigned as ISO_Next_Group key, if you have assigned it as keyboard layout switch key in Keyboard Layout setting tool.

Yes. Now we are able to reproduce the issue on Q4OS and exactly the same way on Debian12 with Trinity desktop. So we conclude upstream bug, please report it for Trinity developers.

Rademes wrote:

Maybe Xkb (X11) asigns LeftWin key as ISO_Next_Group key?

It could be the case.

Offline

#5 2023-09-30 19:52

Rademes
Member
From: Latvia
Registered: 2015-12-13
Posts: 637

Re: [Upstream] Left Win key in keyboard shortcuts.

OK, I have found a temporary workaround, which works for me at least.
First, you need to disable X11 keyboard layout switch shoutcut.
settings:/Accessibility/ ---> Keyboard Layouts ---> Keyboard Shortcuts ---> Key combination to switch layout (X11): NO
Second, you have to edit kdeglobals:
1.  Open in text editor (Kwrite, Kate) file /home/username/.trinity/share/config/kdeglobals
2.  Change two strings. They should be following:
     Popup Launch Menu=Ctrl+Escape
     Switch to Next Keyboard Layout=Alt+Space;Super_L

3.  Reboot the computer.
After reboot you will be able to use LeftWin key as keyboard layout switch key, and you will be able to assign it as Win+ key.
https://mirror.git.trinitydesktop.org/g … ment-33264
https://mirror.git.trinitydesktop.org/g … 0ee243bb3e

Last edited by Rademes (2023-09-30 19:54)


Before asking for help please read this topic: https://www.q4os.org/forum/viewtopic.php?id=3502   If you have problems with WiFi network, try to install the Network Manager using Q4OS Software Centre.

Offline

Board footer

Powered by FluxBB