You are not logged in.

#1 2023-04-07 12:01

hdwolf
Member
Registered: 2023-04-01
Posts: 9

q4os Aquarius Testing Firefox Install fails

I have installed the full desktop with the Firefox Browser. Testing now the software center, I installed also the chrome browser via software center and installation goes fine. After restart, I go to the software center and uninstall the firefox browser. All goes fine. New restart, going to software center and trying to reinstall the firefox browser. The installation fails with "copying system packages..." In german there is a dialogue "Nur Herunterladen Modus aktiv" (only download mode active). The installer window freezes, cause appsetup2 in background hangs up. After restart, a second attempt ends with the same failure.

Update:
Today I had time to retest the behaviour with another machine but with the same configuration. The first retest was without failure, Firefox software center installer did all fine. The difference was, that during install the firefox browser was automatically updated. For confirmation, I uninstalled again the firefox browser, (via software center) restart and reinstall the firefox browser and the failure occured again. This time the installer window not only freezes but said goodbye. Sometimes the cache files could be the reason for and more to try than to know I deleted the .mozilla directory and the cache files in .kdecache. After that, the third attempt with uninstall/reinstall was without failure. Install/uninstall/reinstall with the Google Chrome browser was always without failures.

Last edited by hdwolf (2023-04-16 22:16)

Offline

#2 2023-07-20 14:46

q4OSsimpleUser
Member
Registered: 2023-07-18
Posts: 7

Re: q4os Aquarius Testing Firefox Install fails

Dear Q4OS Team,

Having just installed Q4OS 5.2 (i386) on a VirtualBox test machine, I'm also experiencing a problem installing Firefox with the Software Center (directly accessible at startup by the home screen).

It freezes after a "Copying system packages ..." message : imgur.com/Gr6i5Bh

Thank you.

Best regards,

Offline

#3 2023-07-21 16:37

hdwolf
Member
Registered: 2023-04-01
Posts: 9

Re: q4os Aquarius Testing Firefox Install fails

Hello,
I've checked your screenshot concerning the problem. It is the same message in french like I obtained in german. Perhaps the q4os team can have a look at the install script for firefox, if there is time for it. Perhaps you can try the workaround (see my Update posting).

Best regards

Offline

#4 2023-07-21 18:02

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,334
Website

Re: q4os Aquarius Testing Firefox Install fails

@q4OSsimpleUser
Please try to install Firefox once again and post back.

Offline

#5 2023-08-01 12:28

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,334
Website

Re: q4os Aquarius Testing Firefox Install fails

OP looks to be connected to this bug https://www.q4os.org/forum/viewtopic.php?id=4575

Offline

#6 2023-08-02 19:48

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,334
Website

Re: q4os Aquarius Testing Firefox Install fails

Offline

#7 2023-08-06 11:13

hdwolf
Member
Registered: 2023-04-01
Posts: 9

Re: q4os Aquarius Testing Firefox Install fails

Hello,
today, I've done a new install of Q4OS (Desktop install) and the retest of the Firefox Install test case (see above my initial post) was successful. For me it is solved. Hope this functions for the libreoffice install too. Many thanks to q4os team!

Offline

#8 2023-08-11 11:03

q4OSsimpleUser
Member
Registered: 2023-07-18
Posts: 7

Re: q4os Aquarius Testing Firefox Install fails

Hello,
Sorry, I didn't see your messages...
I just checked the Q4OS updates today, just in case...
Thanks a lot. I'll test it very soon.
Best regards,

Offline

Board footer

Powered by FluxBB