You are not logged in.

#1 2022-07-03 10:17

niftyprose
Member
Registered: 2021-04-10
Posts: 26

[SOLVED] ASUS E210M / Realtek RTL8821CE / Q40S

Hello guys,

I was an enthusiastic early adopter of the netbook concept, and I'm now on my seventh or eighth such machine. Asus usually has in production a small, cheap, lightweight laptop with an SSD drive (even if they don't advertise it). My latest purchase is an E210M, a model which has been around for a couple of years but is still listed on the Asus website.

I've been dealing with iterations of the notorious Linux/wi-fi/non-free issue for more than a decade and I really thought it would have been sorted out by now. To my astonishment, a clean install of the latest Q4OS onto the new machine didn't give me wi-fi, so I had to drive off to the office to collect a USB-Ethernet adapter in order to plug into my router.

I'm not bitching at the excellent Q4OS team, as I'm aware that this is an 'upstream problem'. But I will mention that the fix seems to change every time I deal with it. It seems like every three years or so some friendly hacker posts working drivers on GitHub then abandons the project, leaving a trail of blog posts pointing at solutions that no longer work. It's very, very frustrating.

Anyway, this time out I tried four or five non-working solutions before I hit on a viable fix, and thought I'd share it here. It's documented on this blog, which compiles nine or ten such solutions:

https://easylinuxtipsproject.blogspot.c … altek.html

The one that worked for my machine was the one attributed to 'Larry Finger'.

Hope this helps someone.

Best, NP

Offline

Board footer

Powered by FluxBB