You are not logged in.

#1 2021-08-29 21:00

Werner Holtfreter
Member
Registered: 2016-10-09
Posts: 46

Wrong colors with RadeonHD7770

Hello,

I replaced a defective graphics card with the following one:

root@q4os-desktop:~# lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Cape Verde XT [Radeon HD 7770/8760 / R7 250X] [1002:683d]

The hardware works perfectly, e.g. with Kubuntu and the free driver "radeon". There I can also configure as I like.

Q4OS Centaurus also uses the driver "radeon". But if I change anything using

/opt/trinity/bin/tdecmshell 'displayconfig'

all colors change completely, e.g. brown becomes green.

Normal colors only reappear when I open a text console and type startx from there. But as written, it is not possible to configure the display.

Also after reinstalling Q4OS the same problem.

As a workaround, what file can I delete to make the system restore the default configuration?

Is there a solution to the problem?

EDIT: Bug Report https://sourceforge.net/p/q4os/tickets/133/ describes similar with severity 1. Is 1 high/critical or low?

Last edited by Werner Holtfreter (2021-09-01 21:02)

Offline

#2 2021-09-26 15:00

Werner Holtfreter
Member
Registered: 2016-10-09
Posts: 46

Re: Wrong colors with RadeonHD7770

Again my question: The Q4OS Team changed the severity of the bug from 4 to 1. Is "1" a high or a low priority?

Offline

#3 2021-09-26 17:46

Tolkem
Member
Registered: 2019-10-06
Posts: 421

Re: Wrong colors with RadeonHD7770

It seems the cape verde is supported by the amdgpu open driver. To find out whether that's the case, you might try this https://itectec.com/ubuntu/ubuntu-which … ntu-16-04/  Then you may try and switch to that one https://wiki.archlinux.org/title/AMDGPU
I've read it works better than radeon. I have an amd gpu too, but it's not supported by amdgpu sad That being said, I've never experienced such an issue like the one you're having, I use Plasma though.

Offline

#4 2021-09-27 10:03

Werner Holtfreter
Member
Registered: 2016-10-09
Posts: 46

Re: Wrong colors with RadeonHD7770

My current driver "radeon" works perfektly when I start the desktop from a text console with startx. Only something of the configuration is broken in TDE or in Q4OS. When I have more time I should test debian. I assume, debian with TDE is also lightweigt as Q4OS. Correct me if I am wrong.

Offline

Board footer

Powered by FluxBB