You are not logged in.

#1 2018-12-26 01:24

jajk
Member
Registered: 2018-12-26
Posts: 3

Freeze part way through install and no boot

I am trying to install 3.4 onto an Acer ES1-533-C2UM laptop with a known troublesome UEFI implementation.
I have previously manged to install Manjaro by manually moving and renaming grub files but cannot for the life of me do the same for Q4OS.
Clean install from Live USB crashes at 79% "Starts procedure and passes 'fw_type' to other routine" and the laptop does not find an OS on reboot. It looks like the OS is full installed but grub has failed to install correctly.
I need help to manually install grub onto the efi partition if someone can assist?

Offline

#2 2018-12-26 11:33

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,532
Website

Re: Freeze part way through install and no boot

On reboot can you access the boot options? My Dell laptop uses F12 for this (at Dell splash screen) but it could be a different option on yours. This might show you the Q4OS option to boot into, although if your installation failed at 79% it is possible that no grub has been installed and the system may not be bootable.

Offline

#3 2018-12-27 02:07

jajk
Member
Registered: 2018-12-26
Posts: 3

Re: Freeze part way through install and no boot

The laptop has crippled options in the BIOS - Acer and Microsoft trying to prevent users from installing a better OS than the Win10 rubbish it came with. I have successfully had Manjaro running by manually installing grub and shifting/renaming the files to keep the BIOS happy. It crashed to at a similar point in the install due to some probing by grub.
I now need to do the same.....manually install grub. The live USB does not seem to give me access to the grub commands so I am at a bit of a loss?

Offline

#4 2018-12-27 10:17

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,532
Website

Re: Freeze part way through install and no boot

The Live-Cd (on usb stick) will give you the working environment needed to create a chroot environment to install grub from the installed system, I have outlined the procedure in this post which might help, but one more thing you would need to do is mount the efi partition in the chroot environment to be able to install grub to it
My efi boot partition is sda2 so I would mount it using this (in the linked post example)

sudo mount --bind /dev/sda2 $TARGET/boot/efi

One thing to check would be that grub-efi is installed in the chroot, if not it can be easily installed with

apt install grub-efi

and then grub installation would be like this

grub-install

After this has completed you can exit the chroot and unmount it then reboot the system, hopefully it will give you the boot entry you need.

Offline

#5 2018-12-27 10:57

jajk
Member
Registered: 2018-12-26
Posts: 3

Re: Freeze part way through install and no boot

Thank you Dai_trying that looks like what I need.
I will report back on the outcome.

Offline

Board footer

Powered by FluxBB