You are not logged in.

#1 2018-08-05 21:28

ron34
Member
Registered: 2018-08-05
Posts: 1

Firefox Quantum - hide the title bar

Hello, Firefox Quantum contains a checkbox in the customization options to disable the title bar. It appears that this option is not working in TDE. Does anyone know how to resolve this issue?

Your help is appreciated, thanks.

FluxBB bbcode test

Offline

#2 2018-08-05 22:18

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

Yes, we can confirm this option doesn't work in TDE, while in KDE Plasma works fine. It looks like this option isn't fully compatible with the 'twin' window manager. We will consider to report a new bug at the TDE developers https://bugs.trinitydesktop.org/buglist … search=ALL , you are welcome to report it as well.

Offline

#3 2018-09-25 10:45

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

Offline

#4 2022-05-14 16:42

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

I'm still facing this issue in the latest Firefox ESR and the latest Q4OS Gemini 4.8. Are there any workarounds? Or did I miss something?

Last edited by Midas (2022-05-14 16:55)

Offline

#5 2022-05-15 05:30

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,182

Re: Firefox Quantum - hide the title bar

'Works for me' is never a lot of help, but I have found this works OK with Q4OS Gemini TDE and Firefox ESR and Firefox Quantum 100.2 using the static binary.

If it is of any relevance, this 'feature' works as expected using Trinity TDE 14.0.12 on vanilla Debian Bullseye (11) and Firefox ESR 91.9 as well as the latest Firefox 100.2 using the downloaded static binary.

In both cases I have GTK3 style support installed.

Last edited by bin (2022-05-15 05:50)

Offline

#6 2022-05-16 13:18

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

I see. Thanks for the info, bin. cool

What would you suggest I try -- uninstall the repo version and go with the static binary?

And how does one install that?

Does GTK3 support need to be installed, too?

Offline

#7 2022-05-16 14:33

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

bin wrote:

In both cases I have GTK3 style support installed.

What packages did you install ?

Offline

#8 2022-05-17 05:16

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,182

Re: Firefox Quantum - hide the title bar

gtk-qt-engine-trinity gtk3-tqt-engine-trinity qtcurve-trinity - along with any recommended

Offline

#9 2022-05-17 10:02

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,182

Re: Firefox Quantum - hide the title bar

Midas wrote:

I see. Thanks for the info, bin. cool

What would you suggest I try -- uninstall the repo version and go with the static binary?

And how does one install that?

Does GTK3 support need to be installed, too?

I prefer ESR - the standard FF installed from the repo. That way you know it is always up to date.

See above for the packages to install  - you can then configure GTK Styles in Control Centre>Appearance.

I use Q4OS02 as my main style as it is based on qtcurve and so when used for GTK apps it all looks pretty much the same.

Offline

#10 2022-05-18 14:22

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

If you export "GTK_CSD=1" environment variable, hiding the title bar works properly for any version of Firefox under all desktop environments including Trinity. We will try to search for more general and clean fix in Q4OS.

Offline

#11 2022-05-18 19:51

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

bin wrote:

gtk-qt-engine-trinity gtk3-tqt-engine-trinity qtcurve-trinity - along with any recommended

I did install those, but didn't see any change in behavior.

The following NEW packages will be installed:
  gtk-qt-engine-trinity gtk2-engines-qtcurve{a} gtk3-tqt-engine-trinity libgail-common{a} libgail18{a} libgtk2.0-0{a} libgtk2.0-bin{a} libgtk2.0-common{a} qtcurve-trinity
0 packages upgraded, 9 newly installed, 0 to remove and 0 not upgraded.
Need to get 5,241 kB of archives. After unpacking 28.5 MB will be used.

---

q4osteam wrote:

If you export "GTK_CSD=1" environment variable, hiding the title bar works properly for any version of Firefox under all desktop environments including Trinity. We will try to search for more general and clean fix in Q4OS.

Wasn't sure about how to do that, so here's what I did:

1. $ sudo nano /etc/environment
2. added the following line at the end: export "GTK_CSD=1"

Will now reboot and report back...

---

EDIT: Nope, that didn't work either...

The only thing that seems to work is right clicking the titlebar and choosing "No border" from the "Advanced" sub-menu. Tried setting this permanently with different options through the "Special Windows Settings" and "Special Application Settings" but none of them worked, either.

Last edited by Midas (2022-05-18 23:22)

Offline

#12 2022-05-19 10:16

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

@Midas
Please run Firefox from terminal the way:
$ GTK_CSD=1 firefox
or:
$ GTK_CSD=1 firefox-esr
and post back.

What FF and Q4OS version do you have ?

Offline

#13 2022-05-23 16:53

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

q4osteam wrote:

$ GTK_CSD=1 firefox-esr

Sorry for the delayed answer, but IRL kept me busy.

That incantation did work as intended, hurray.

Although it did spew out a bunch of apparently GTK related errors in the following form:

(firefox-esr:1640): Gtk-WARNING **: 16:33:10.954: Theme parsing error: gtk-widgets.css:[integer]:[integer]: [br]
The style property GtkButton:image-spacing is deprecated and shouldn't be used anymore. It will be removed in a future version

My Firefox is 91.9.0esr (64-bit); 'inxi -F' returns:

System:    Host: q4os-desktop Kernel: 5.10.0-14-amd64 x86_64 bits: 64 Desktop: Trinity R14.0.11 Distro: Q4OS 4.8.1-n2
Machine:   Type: Laptop System: LENOVO product: 20FAS6QJ00 v: ThinkPad T460s serial: <superuser required>
           Mobo: LENOVO model: 20FAS6QJ00 v: SDK0J40697 WIN serial: <superuser required> UEFI [Legacy]: LENOVO
           v: N1CET84W (1.52 ) date: 07/08/2021
Battery:   ID-1: BAT0 charge: 16.7 Wh condition: 21.4/23.5 Wh (91%)
           ID-2: BAT1 charge: 21.2 Wh condition: 21.2/26.1 Wh (81%)
CPU:       Info: Dual Core model: Intel Core i7-6600U bits: 64 type: MT MCP L2 cache: 4 MiB
           Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics:  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
           Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.11 driver: loaded: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.5
Audio:     Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
           Sound Server: ALSA v: k5.10.0-14-amd64
Network:   Device-1: Intel Ethernet I219-LM driver: e1000e
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: c8:5b:76:c9:d5:17
           Device-2: Intel Wireless 8260 driver: iwlwifi
           IF: wlp4s0 state: down mac: f4:8c:50:29:e2:a3
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb
           Report: ID: hci0 state: up running bt-v: 2.1 address: F4:8C:50:29:E2:A7
Drives:    Local Storage: total: 465.76 GiB used: 5.43 GiB (1.2%)
           ID-1: /dev/nvme0n1 vendor: Kingston model: SNVS500G size: 465.76 GiB
Partition: ID-1: / size: 14.71 GiB used: 5.43 GiB (36.9%) fs: ext4 dev: /dev/dm-1
Swap:      ID-1: swap-1 type: partition size: 975 MiB used: 0 KiB (0.0%) dev: /dev/dm-3
Sensors:   System Temperatures: cpu: 37.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 158 Uptime: 16m Memory: 7.19 GiB used: 1.65 GiB (22.9%) Shell: Bash inxi: 3.3.01

Now, any quick way to make the change permanent?

Offline

#14 2022-05-25 13:23

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

Midas wrote:

Any quick way to make the change permanent?

Pretty please? neutral

Offline

#15 2022-05-25 17:16

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,587
Website

Re: Firefox Quantum - hide the title bar

Midas wrote:

Now, any quick way to make the change permanent?

Create file "/etc/X11/Xsession.d/99-my-environment-vars" containing:

export GTK_CSD=1

login again and check the result.

Offline

#16 2022-05-26 17:37

Midas
Member
Registered: 2017-12-15
Posts: 141

Re: Firefox Quantum - hide the title bar

q4osteam wrote:

Create file "/etc/X11/Xsession.d/99-my-environment-vars" containing:

export GTK_CSD=1

login again and check the result.

Thanks, that worked perfectly (via 'sudo nano /etc/X11/Xsession.d/99-my-environment-vars').

Problem solved. cool

Offline

Board footer

Powered by FluxBB