You are not logged in.

#1 2018-06-23 11:20

Jedi
Member
Registered: 2018-06-23
Posts: 15

Multimedia codecs

When I attempt to install proprietary codecs from the Q4OS welcome screen i get "Simulation not successful, sorry, I cannot install now."

In the dialouge box i see

sudo: sorry, you are not allowed to set the following environment variables: DEBCONF_FRONTEND, DEBIAN_FRONTEND

Does anyone know what is happening here?

Offline

#2 2018-06-23 11:26

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

What DE are you attempting to run installer from, Plasma or Trinity or other ?
Is the user member of sudo group ?
You can check it using command in terminal:
$ groups

Offline

#3 2018-06-23 12:46

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

DE is Trinity.

Yes I am a member of sudo group, I can become root.

Offline

#4 2018-06-23 13:43

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

It seems you have configured sudo permissions some incompatible way. We are not able to reproduce that on a clean Q4OS installation, so need some more info.
Please run in terminal:
$ sudo DEBCONF_FRONTEND=test env | grep DEBCONF_FRONTEND
$ sudo VAR1=test env | grep VAR1
$ sudo cat /etc/sudoers /etc/sudoers.d/* | grep -v ^# | grep -v ^$
and post output here to analyze.

Offline

#5 2018-06-23 14:16

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

sudo DEBCONF_FRONTEND=test env | grep DEBCONF_FRONTEND
[sudo] password for mike:
DEBCONF_FRONTEND=test

sudo VAR1=test env | grep VAR1
VAR1=test

sudo cat /etc/sudoers /etc/sudoers.d/* | grep -v ^# | grep -v ^$
Defaults    env_reset
Defaults    mail_badpass
Defaults    secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"
root    ALL=(ALL:ALL) ALL
%sudo    ALL=(ALL:ALL) ALL
Defaults env_keep="DISPLAY"
%sudo    ALL = NOPASSWD: /usr/bin/apt-get *
%sudo    ALL = NOPASSWD: /usr/bin/apt-key *
%sudo    ALL = NOPASSWD: /usr/bin/dpkg *
Defaults env_keep += "DEBCONF_FRONTEND DEBIAN_FRONTEND"
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/appsetup2_helper.sh *
Defaults timestamp_timeout=30
Defaults !tty_tickets
Defaults lecture=never
Defaults env_keep += "DISPLAY XAUTHORITY XDG_DATA_DIRS GTK_RC_FILES GTK2_RC_FILES QAPTDISTR"
Defaults env_keep += "ftp_proxy http_proxy https_proxy no_proxy"
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/q4sudo.sh *
Defaults secure_path=/usr/local/sbin:/usr/local/bin:/opt/trinity/sbin:/usr/sbin:/opt/trinity/bin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

Offline

#6 2018-06-24 12:39

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

Looks fine, so we would need more debug info. Please run in terminal:
$ reportq4
and send the debug file generated via email support@q4os.org , or attach it here to analyze.

Anyone else noticed this issue ?

Offline

#7 2018-06-24 23:07

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

Hi,

I have put the full output from the Multimedia Codecs setup wizard below and attached the debug file. Thank you for your help with this.

Calculating progress ...
Testing Internet connection ...
Testing Internet connection ... OK
Extracting archive ...
Extracting archive ... Done
Checking package system ...
Reading package lists... 100%
Reading package lists... Done
Building dependency tree
Reading state information... 0%
Reading state information... Done
Verified ... OK
Autofix not needed ... OK
Waiting to complete current operation ... Done
Adding security keys ...
Adding security keys ... OK
Preparing installation files ...
Preparing installation files ... OK
Partial update sw database ...
sudo: sorry, you are not allowed to set the following environment variables: DEBCONF_FRONTEND, DEBIAN_FRONTEND
Partial update sw database ... Done
Update sw database ...
sudo: sorry, you are not allowed to set the following environment variables: DEBCONF_FRONTEND, DEBIAN_FRONTEND
Update sw database ... Done
Testing installation ...
sudo: sorry, you are not allowed to set the following environment variables: DEBCONF_FRONTEND, DEBIAN_FRONTEND
Testing installation ... Done


Attachments:
gz qreport.tar.gz, Size: 48.04 KiB, Downloads: 52

Offline

#8 2018-06-25 08:03

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

Just a bit more information which may or may not be helpful.

When I installed the OS I set up a separate partition for my my home folder. After installation I decided I wanted this partition to be LVM. As far as I could tell the only way to achieve this was to move the home folder to another partition, format the partition to LVM then put the home folder back on it. I remember editing the /etc/passwd file during this process. If I have messed up a config file somewhere it was most likely during this process.

Offline

#9 2018-06-25 22:33

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

Well, we are now able to reproduce the issue. It looks like you have the line:

Defaults env_keep="DISPLAY"

within a file from '/etc/sudoers.d/*' directory. If you will comment out this line, we are pretty sure, the installation of codecs will pass fine. It would be helpful, if you would post a filename and possibly origin of this particular file for us to be able definitely fix and prevent this issue from Q4OS. Thanks for reporting.

Offline

#10 2018-06-26 00:17

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

There are 5 files within /etc/sudoers.d/ directory, none of which are hidden. I have listed each one (except README) with their contents below (I have put parenthesis around each filename to differentiate it from the contents of the file):

(30_q4os_apt)

# apt-get command
%sudo    ALL = NOPASSWD: /usr/bin/apt-get *
%sudo    ALL = NOPASSWD: /usr/bin/apt-key *
%sudo    ALL = NOPASSWD: /usr/bin/dpkg *

Defaults env_keep += "DEBCONF_FRONTEND DEBIAN_FRONTEND"

(35_appsetup2_helper)

# appsetup2 sudo helper
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/appsetup2_helper.sh *

(q4_sudo_confd)

Defaults timestamp_timeout=30
Defaults !tty_tickets
Defaults lecture=never

# Defaults env_reset
Defaults env_keep += "DISPLAY XAUTHORITY XDG_DATA_DIRS GTK_RC_FILES GTK2_RC_FILES QAPTDISTR"

Defaults env_keep += "ftp_proxy http_proxy https_proxy no_proxy"

# q4os passwordless helper
%sudo    ALL = NOPASSWD: /bin/dash /usr/share/apps/q4os_system/bin/q4sudo.sh *

(tde-secure-path)

Defaults
secure_path=/usr/local/sbin:/usr/local/bin:/opt/trinity/sbin:/usr/sbin:/opt/trinity/bin:/usr/bin:/sbin:/bin:/usr/X11R6/bin

Offline

#11 2018-06-26 07:12

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

So the line 'Defaults env_keep="DISPLAY"' must be in the '/etc/sudoers' file, please paste its contents here as well.

Offline

#12 2018-06-26 09:09

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

I went to put it there and found its already there.

Would it help if I installed Team Viewer so you could have a look in real time?

Also to be clear I have not made any changes to any files in the  /etc/sudoers.d/ directory. They are all as posted above.

Offline

#13 2018-06-26 09:30

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

You have put all files from the '/etc/sudoers.d/' directory, but not the '/etc/sudoers' file. It's a different file, we need to check just this one. Unfortunately, we don't want to use Team Viewer for community support.

Offline

#14 2018-06-26 17:37

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,375
Website

Re: Multimedia codecs

It sounds like that line is in the /etc/sudoers file and the OP just needs to remove/comment it.

Jedi wrote:

I went to put it there and found its already there.

Offline

#15 2018-06-26 21:52

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 1,944
Website

Re: Multimedia codecs

Dai_trying wrote:

It sounds like that line is in the /etc/sudoers file and the OP just needs to remove/comment it.

Oh see now. So the OP needs to edit the '/etc/sudoers' file and remove the line:

Defaults env_keep="DISPLAY"

Offline

#16 2018-06-27 00:45

Jedi
Member
Registered: 2018-06-23
Posts: 15

Re: Multimedia codecs

Sorry I missread that. I have commented the line out of the sudoers file and am very pleased to report the codecs successfully installed. Thank you very much for this, I really appreciate your time and patience in resolving this issue.

Offline

Board footer

Powered by FluxBB