You are not logged in.

#1 2017-07-04 21:40

madalex
Member
Registered: 2017-07-04
Posts: 14

Switching keyboard layouts

Dear sirs,
please help me to set up switch keubuard layouts using Ctrl+Shift shortcut. Despite it is mentioned in Xkb Otions, it DOES NOT WORK COMPLETELY!

Offline

#2 2017-07-04 23:58

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,971
Website

Re: Switching keyboard layouts

Providing you have set up multiple languages you can select a different keyboard layout with Alt+Ctrl+K or Alt+Space.

Offline

#3 2017-07-05 05:43

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,147

Re: Switching keyboard layouts

Aslo, just in case, do make sure that you have enabled Keyboard Layouts in Control Centre

Control Centre>Regiional & Accessibilty>Keyboard Layout  Check 'Enable Keyboard Layouts'

Make sure the relevant language is in the list on the right hand side and that you have enabled Xkb Options on the Xkb Options tab

Offline

#4 2017-07-05 07:34

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

Dai_trying wrote:

Providing you have set up multiple languages you can select a different keyboard layout with Alt+Ctrl+K or Alt+Space.

Well, these combinations do work. But I have asked about Ctrl+Shift especially.

Offline

#5 2017-07-05 07:44

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

bin wrote:

Aslo, just in case, do make sure that you have enabled Keyboard Layouts in Control Centre

Control Centre>Regiional & Accessibilty>Keyboard Layout  Check 'Enable Keyboard Layouts'

Make sure the relevant language is in the list on the right hand side and that you have enabled Xkb Options on the Xkb Options tab

Yes, Keyboard Layouts are enabled, and standard Alt+Space or Alt+Ctrl+K combinations really switch layouts. Yes, Xkp options are enabled too, but these ones do not work.


Attachments:
png XkpOptions01.png, Size: 52 KiB, Downloads: 517

Offline

#6 2017-07-05 10:22

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,971
Website

Re: Switching keyboard layouts

madalex wrote:

Yes, Keyboard Layouts are enabled, and standard Alt+Space or Alt+Ctrl+K combinations really switch layouts. Yes, Xkp options are enabled too, but these ones do not work.

I just tried and the options you have shown as selected don't change keyboard layout for me either... Is there any reason you do not want to use the standard keyboard shortcuts? I haven't used Xkb and don't usually have it enabled so not sure what benefits it would have.

Offline

#7 2017-07-05 21:58

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

Dai_trying wrote:

[
I just tried and the options you have shown as selected don't change keyboard layout for me either... Is there any reason you do not want to use the standard keyboard shortcuts? I haven't used Xkb and don't usually have it enabled so not sure what benefits it would have.

There are not so mush reasons to use exactly Ctrl+Shift (however, I'd like to use it), but I just wonder why this options are present but do not work at all, just slightly more than completely... :-) Why on the earth they are there?

Offline

#8 2017-07-05 22:24

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

madalex wrote:

There are not so mush reasons to use exactly Ctrl+Shift (however, I'd like to use it), but I just wonder why this options are present but do not work at all, just slightly more than completely... :-) Why on the earth they are there?

Just for another example - this option (please see XkbOptions02.png attached) does not work, too.
And sure, I have KHotKeys daemon enabled, too (see ActionsSettings.png followed)

Last edited by madalex (2017-07-05 22:26)


Attachments:
png XkpOptions02.png, Size: 64.78 KiB, Downloads: 565

Offline

#9 2017-07-05 22:25

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

+

Last edited by madalex (2017-07-05 22:25)


Attachments:
png ActionsSettings.png, Size: 29.69 KiB, Downloads: 525

Offline

#10 2017-07-05 22:41

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,971
Website

Re: Switching keyboard layouts

It seems strange that none of the Xkb options I have tried work... I also tried to set the alternative keyboard shortcut to Ctrl+Shift but that would not get accepted, instead it gives Ctrl+ISO_Next_Group as the shortcut??? and pressing Ctrl +Shift does nothing... weird...

Offline

#11 2017-07-06 05:42

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,147

Re: Switching keyboard layouts

I'm pretty sure it is now part of the Trinity installation - but worth checking that ~./trinity/Autostart folder contains a symlink to /opt/trinity/bin/khotkeys

Offline

#12 2017-07-06 06:35

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

Dai_trying wrote:

It seems strange that none of the Xkb options I have tried work... I also tried to set the alternative keyboard shortcut to Ctrl+Shift but that would not get accepted, instead it gives Ctrl+ISO_Next_Group as the shortcut??? and pressing Ctrl +Shift does nothing... weird...

I tried this, too - with the same result.

Offline

#13 2017-07-06 06:42

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

bin wrote:

I'm pretty sure it is now part of the Trinity installation - but worth checking that ~./trinity/Autostart folder contains a symlink to /opt/trinity/bin/khotkeys

I do not have such a symlink there...

Offline

#14 2017-07-06 09:39

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,147

Re: Switching keyboard layouts

Worth trying this followed by a restart

The first letter is a lower case L

ln -s /opt/trinity/bin/khotkeys /home/your user name/.trinity/Autostart/autostart_khotkeys

Offline

#15 2017-07-06 23:56

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

bin wrote:

Worth trying this followed by a restart

The first letter is a lower case L

ln -s /opt/trinity/bin/khotkeys /home/your user name/.trinity/Autostart/autostart_khotkeys

No effects, absolutely.

Offline

#16 2017-07-07 08:02

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,147

Re: Switching keyboard layouts

Sorry, but I'm fresh out of ideas with this - keyboard language icon in system tray works though.

Offline

#17 2017-07-07 10:10

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,971
Website

Re: Switching keyboard layouts

I think this may have something to do with the fact that Ctrl+Shift is already used as part of the function for text selection, for instance if you press Ctrl+Shift+(left/right/up/down) cursor keys it will highlight (select) text by line or word. If user were to use Ctrl+Shift as a keyboard shortcut it would disable this function. I don't know exactly but I figure this would probably be affecting this...

Offline

#18 2017-07-07 10:15

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,147

Re: Switching keyboard layouts

Good point Dai.

Offline

#19 2017-07-08 09:38

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,523
Website

Re: Switching keyboard layouts

We will take a look on that and post a result in a few days

Offline

#20 2017-07-17 18:09

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

q4osteam wrote:

We will take a look on that and post a result in a few days

Seems it takes not so few days, yeah? ;-)

Offline

#21 2017-07-17 18:18

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,523
Website

Re: Switching keyboard layouts

@madalex
Sorry for the delay, we are now busy with another tasks. It will be checked in detail and posted as soon as possible, hopefully till the end of the week. As a preliminary result we guess, it could be a Trinity bug. If a bug will be confirmed, we will immediately file it at TDE bug tracker.

Offline

#22 2017-07-18 18:43

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

@q4osteam
Ok, no problem, I'll wait.

Offline

#23 2017-07-19 11:46

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,523
Website

Re: Switching keyboard layouts

We can confirm a buggy behavior of "Xkb options" in TDE. If set, it doesn't work for some shortcuts, for example keyboard layout switching. However, it will start to work once a keyboard layout is switched manually in the system tray. After that, the keyboard shortcut "ctrl+shift" switches keyboard layout, with the flag indication in the system tray remaining unchanged.

We will report these findings as a bug in the Trinity bug tracker. Thanks all for reporting.

Offline

#24 2017-07-19 18:50

madalex
Member
Registered: 2017-07-04
Posts: 14

Re: Switching keyboard layouts

Unfortunately, in my case it doe not work even if I switch keyboard layout manually in the system tray several times. :-(

Offline

#25 2018-08-06 13:19

plambi
Member
From: BG
Registered: 2018-08-06
Posts: 3

Re: Switching keyboard layouts

Universal kbd layout switching method and tool:

For all of you - here is the cure for a long time known KDE 3 problem - switching with some key combinations, specially with Alt+Shift.

1. Open Synaptic --> Search for: kkbswitch-trinity (current ver. 4:14.0.4) and install it.
2. Open Trinity Control Panel --> Regional & Accessibility --> Keyboard Layout
3. Remove ANY kind of ENGLISH layout you have and JUST add your local (native) language. In my case - Bulgarian.
4. Very important step: please, check "Include latin layout" with your native layout.
5. Goto "Swithing Options" Tab
6. Uncheck "Show indicator for single layout" and "Show country flag" - these will be maintained by KKBSwitch application.
7. Goto "Xkb Options" Tab
8. Here, you can choose switching combinations you like - in my case - Alt+Shift

That all, you may close Trinity Control Center now and start KKBSwitch ( Alt+F2 --> kkbswitch)
Probably, you won't see English and your country flag at first, so feel free to set them up from "Settings" on KKBSwitch.

Step-by-step screenshots:

snapshot1.png
snapshot2.png
snapshot3.png
snapshot4.png
snapshot5.png

Hope this helps. Greetings from sunny Buglaria!

Last edited by plambi (2019-10-04 17:35)


HP z230 SFF, Xeon E3-1226 v3, 16 GB DD3L ECC, nVidia Quadro K4000, registered linux user #413596

Offline

Board footer

Powered by FluxBB