You are not logged in.

#1 2017-06-23 07:08

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

*SOLVED* Boot problems [scorpion] with my netbook

I want to use Q4OS Scorpion on my netbook DELL Inspiron mini 1012.
The live version runs without problems from an USB stick.

After installation and rebooting the boot procedure stops after the following display:

...
[ OK ] Listening on Load/Save RF Kill Switch Status...
[ OK ] Started Load/Save RF Kill Switch Status.

Nothing happens after that.

The Q4OS Orion works good on this netbook.
I use also Q4OS Scorpion on my  laptop DELL VOSTRO 1520 without problems.

Last edited by BSpinoza (2018-01-23 15:32)

Offline

#2 2017-06-23 12:01

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: *SOLVED* Boot problems [scorpion] with my netbook

I haven't come across this issue myself, but can you elaborate more on "Nothing happens after that?"

Does the machine just display the terminal output and appear "frozen"?
Does the display go to blank screen with curser at top left position?

And as the live-cd does work, could you install inxi in the live session and post the output of inxi -F

Offline

#3 2017-06-23 12:11

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

@Dai_traying: The terminal output appears "frozen".
Pls. see attached picture.
The output of inxi I will send later.

Offline

#4 2017-06-23 12:14

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

@Dai_traying: The terminal output appears "frozen".
Pls. see attached picture.
The output of inxi I will send later.


Attachments:
jpg Anzeige boot.jpg, Size: 171.18 KiB, Downloads: 744

Offline

#5 2017-06-23 17:42

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

... and now the inxi output....

adminq@debian:~$ inxi -F
System:    Host: debian Kernel: 4.9.0-2-686-pae i686 (32 bit)
           Desktop: KDE Plasma 3 Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: portable System: Dell product: Inspiron 1012 v: A07
           Mobo: Dell model: 0P9MDV v: A07 BIOS: Dell v: A07 date: 03/26/2010
Battery    BAT1: charge: 35.4 Wh 90.3% condition: 39.2/57.7 Wh (68%)
CPU:       Single core Intel Atom N450 (-HT-) cache: 512 KB
           clock speeds: max: 1667 MHz 1: 1000 MHz 2: 1333 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           Display Server: X.Org 1.19.2 drivers: intel (unloaded: modesetting,fbdev,vesa)
           Resolution: 1024x600@60.00hz
           GLX Renderer: Mesa DRI Intel Pineview M x86/MMX/SSE2
           GLX Version: 2.1 Mesa 13.0.6
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-2-686-pae
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169
           IF: enp5s0 state: down mac: 00:26:b9:d3:23:9e
           Card-2: Broadcom Limited BCM4312 802.11b/g LP-PHY
           driver: b43-pci-bridge
           IF: wlan0 state: up mac: 78:e4:00:44:40:48
Drives:    HDD Total Size: 161.1GB (0.4% used)
           ID-1: /dev/sda model: WDC_WD1600BEVT size: 160.0GB
           ID-2: /dev/sdb model: Name n/a size: 1.0GB
Partition: ID-1: / size: 498M used: 175M (36%) fs: overlay dev: N/A
Sensors:   System Temperatures: cpu: 54.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 130 Uptime: 15 min Memory: 153.5/994.6MB
           Client: Shell (bash) inxi: 2.3.5

Offline

#6 2017-06-23 19:24

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: *SOLVED* Boot problems [scorpion] with my netbook

I can't see anything obvious that would cause an issue, one thing I would try is to install using the standard iso to see if that gives the same problem. I am going to perform a VB install to see how it goes for me and post back with results.

EDIT:
Live-cd installed without issue in a VM so I would have thought it to be something hardware specific.

While I think about it can you start your machine in recovery mode to see if that will complete the boot sequence? You might need to press escape to get the grub menu to appear and then select Advanced options for Q4OS (Don't worry if it says Orion is the desktop) and then select the recovery mode option.
If that boots ok you could install inxi and see if there is anything different in the output of inxi -F (apart from hdd info) and that might tell us something significant.

Last edited by Dai_trying (2017-06-23 20:00)

Offline

#7 2017-06-23 20:04

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: *SOLVED* Boot problems [scorpion] with my netbook

I was just doing a few checks and I installed Orion and not scorpion!!! I will try again with the correct iso and post back....

EDIT:
Ok installed the right one this time and everything ran smoothly again, so it might be worth trying a fresh install to see if it might have been a glitch on your last attempt (if recovery mode from my previous post doesn't work).

Last edited by Dai_trying (2017-06-23 20:57)

Offline

#8 2017-06-23 22:12

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

Try using nomodeset at boot or set nomodeset at install with Scorpion and it should be fine.   Orion for that netbook though would be the better option.
Ive seen this before with this netbook but cant be sure its the problem in your case.

Last edited by crosscourt (2017-06-23 22:32)


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

#9 2017-06-23 22:33

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: *SOLVED* Boot problems [scorpion] with my netbook

I wasn't sure if it would be a graphics problem due to it not displaying a blank screen (most common symptom I have read) and yes Orion works well on it already smile
I also noticed that the cpu is 64 bit so that might be another complicating factor although 32 bit should work just as well (in fact maybe better).

Offline

#10 2017-06-23 22:37

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

With that netbook 32bit would be the best choice. Graphics problems can happen without a blank screen and typically the older netbooks with older bios and the earlier Intel Gpu can have issues with 4.9 kernel.  My results vary but typically the older systems prefer Orion with the older kernel 3.16


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

#11 2017-06-24 01:54

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

The other issue many experience is problems ACPI and with older hardware and bios many times there isnt a quick fix.


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

#12 2017-06-24 04:32

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

Many thanks for your answers !
If I install Q4OS Scorpion 32 bit or 64bit the result is the same symptome.
I think the easiest way is that I stay with Q4OS Orion, the 64 bit Version worked always fine.
In the past with all Linux distros with kernel 4.x I had booting problems with this netbook.

Offline

#13 2017-06-24 07:06

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: *SOLVED* Boot problems [scorpion] with my netbook

You're welcome smile
And I think Orion will be supported for quite some time yet, and I would hope that before that ends we may see some compatibility workarounds for the older machines that we can still use.

Offline

#14 2017-06-24 16:10

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

If you change your mind and try to install Scorpion, use nomodeset and turn off ACPI/noACPI and it may work, otherwise enjoy Orion.

Ive got quite a few systems from that period of time desktop/ laptops(many are Dell) and have had some issues with the 4.9 kernel, 4.4 kernel typically works fine


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

#15 2017-06-25 04:53

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

Thank you, crosscourt, for this advice.
I will check this!

Offline

#16 2017-06-25 16:17

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

smile


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

#17 2018-01-21 20:31

BSpinoza
Member
From: Germany
Registered: 2016-03-26
Posts: 30

Re: *SOLVED* Boot problems [scorpion] with my netbook

SOLVED!

I have solved my problem with my Dell Inspiron mini 1020:  Initial boot after installation works, all subsequent boots freeze.


Code:

sudo systemctl mask systemd-backlight@leds\:dell\:\:kbd_backlight.service

The keyboard backlight service is then masked and won't freeze the system when a kernel version greater than 4.0.8 starts.

I found this here:
https://ubuntuforums.org/showthread.php?t=2332063

Q4OS Scorpion boots and runs without any issue! I'm happy!

Offline

#18 2018-01-21 20:36

crosscourt
Member
Registered: 2017-05-07
Posts: 1,807
Website

Re: *SOLVED* Boot problems [scorpion] with my netbook

Thanks for the info, glad you got it working. Ive never experienced nor seen this issue before and I came from the Ubuntu side of things initially.


Q4OS Aquarius 5.1 KDE   Lenovo Thinkcentre M900 Tiny i5-6500T, 16gb ddr4 ram, 512gb m.2 ssd

Offline

Board footer

Powered by FluxBB