You are not logged in.

#1 2015-12-26 09:44

Seeker
Member
From: Surface Of The Earth
Registered: 2015-12-21
Posts: 89

How to enable i386 or 32 bits architecture on Q4OS 64 bits.

Open terminal & type these 2 sudo spells & hit enter each of them:

sudo dpkg --add-architecture i386
sudo apt-get update

Anyone who want to install .deb that comes with i386 architecture
will alert in gdebi as wrong architecture Unlike Ubuntu right?

This will fix for those who can't install .deb files on Q4OS 64 bits with i386(32 bits architecture).
This will be useful for who need to install i386(32 bits) applications
This also need to do on Debian as well. Debian doesn't unlock 32 bits architecture
so you need to unlock this first so you can install stuff from Gdebi.

PS. This also worked for who want to install Teamviewer 11 on i386.deb installer

Offline

#2 2016-09-24 18:18

ghostdawg
Member
From: USA
Registered: 2016-09-19
Posts: 69

Re: How to enable i386 or 32 bits architecture on Q4OS 64 bits.

Seeker thank you for this tip. I just went through something similar after installing my 32 bit Brother printer drivers. Then I went to install the multimedia codecs and got the error about "The following packages have an unknown foreign architecture, which will
cause dependency issues on front-ends. This can be fixed by registering
the foreign architecture with dpkg --add-architecture". I didn't know what to put in there. Adding "dpkg --add-architecture i386" solved my problem.


Dell Optiplex 760 - Quad Core | 4gb | 250gb | Mageia 5, Salix 14.2, Q4OS
Lenovo Thinkpad T420 | 4gb | 120gb | Mageia 5, Debian Testing

Offline

Board footer

Powered by FluxBB