You are not logged in.

#1 2016-09-22 16:37

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

VLC Crashes

I am trying to watch a video using VLC and each time it just crashes out. I started from the command line and this is the output.

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000001b9b718] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000001acd118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007f87c0001268] xcb_xv vout display error: no available XVideo adaptor
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb

Never had a problem with VLC before, so am thinking this could be either due to using newer kernel or newer hardware not fully supported yet???

Offline

#2 2016-09-22 16:56

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Not sure if I have done the right thing but I installed nvidia-vdpau-driver and it would appear to have solved the problem.

Offline

#3 2016-09-22 18:32

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Just a question, did you install proprietary NVIDIA driver before ?

Offline

#4 2016-09-22 18:44

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

No, I hadn't installed any other drivers as everything seemed to be working, I googled about and read a similar problem and that was a suggestion, I still have errors but at least vlc stays open for me to see the video now. I will post the current error messages later (not in q4os at the moment).

EDIT:

here is the command line when I play a video now.

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000001555418] pulse audio output error: PulseAudio server connection failure: Connection refused
[000000000145b118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
modprobe: ERROR: ../libkmod/libkmod-module.c:816 kmod_module_insert_module() could not find module by name='nvidia_current'
modprobe: ERROR: could not insert 'nvidia_current': Function not implemented
modprobe: ERROR: ../libkmod/libkmod-module.c:816 kmod_module_insert_module() could not find module by name='nvidia_current'
modprobe: ERROR: could not insert 'nvidia_current': Function not implemented
[00007f6a24001268] xcb_xv vout display error: no available XVideo adaptor
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

I don't need the nvidia driver as I have a Graphics:  Card: Intel Device 22b1 as reported by inxi but definately not nvidia. Should I remove that driver and install something else to fix this issue?

Last edited by Dai_trying (2016-09-22 18:59)

Offline

#5 2016-09-22 19:36

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

I removed the nvidia driver and now the error messages are ...

VLC media player 2.2.1 Terry Pratchett (Weatherwax) (revision 2.2.1-0-ga425c42)
[0000000000a4b418] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000000951118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007f48e4001268] xcb_xv vout display error: no available XVideo adaptor
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

But the video plays, so it's working at least. I can't figure out why VLC wants the nvidia driver file though any ideas?
I checked using speccy in Win 10 and the graphics are just reported as Intel HD Graphics (Dell)
        Intel HD Graphics
            Manufacturer    Intel
            Model    HD Graphics
            Device ID    8086-22B1
            Revision    22
            Subvendor    Dell (1028)
            Current Performance Level    Level 0
            Driver version    10.18.15.4256
                Count of performance levels : 1


                    Level 1 - "Perf Level 0"

Offline

#6 2016-09-23 05:58

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,319

Re: VLC Crashes

Just an odd thought - did you by any chance bring your /.config/vlc over from your old machine?

What happens if you trash that folder and try again?

Offline

#7 2016-09-23 10:08

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

@crosscourt
    I bought the laptop and Win10 came with it so I thought I would see how it functioned, I also have some friends who I support that have new machines so it will make it easier for me to help if I can see something working on my own system. And if I am totally honest it's a lot better than I was expecting, I have had no issues that my friends have had and it runs like a dream (I still can't believe I'm posting that comment!) but I did do a completely fresh install without all the accompanying software that you get with new pc's/laptops and I think that may have a lot to do with it. I am scheduled to do two Win10 reinstalls without the bloat for friends after they saw how responsive my system is. But I still multi-boot and Linux is the first boot option smile

@bin
    I didn't copy any config files over, but I will try removing that later and see how I get on I'm not on the laptop at the moment so can't try it just yet, and thanks for the suggestion smile

Offline

#8 2016-09-23 10:53

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

@bin
    I tried removing the .config files for vlc and it had little (or no) effect but it was worth a try smile

I have noticed though I have no sound in my Orion system and am now wondering if I have a bad installation so will do another one later to test. My Scorpion system works fully with sound although I still get the errors on the command line

Scorpion errors:

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000000aea248] pulse audio output error: PulseAudio server connection failure: Connection refused
[00000000009ef148] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_i965.so: cannot open shared object file: No such file or directory
QObject::~QObject: Timers cannot be stopped from another thread

Orion errors in post #5

Offline

#9 2016-09-23 12:10

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

@Dai_trying
First of all, you could try to install and run 'vdpauinfo' utility:
$ sudo apt-get install vdpauinfo
$ vdpauinfo

Try to install packages below one-by-one, and test separate results.
- vdpau-va-driver
- mesa-vdpau-drivers
- libvdpau-va-gl1
- nvidia-vdpau-driver

Please report back.

Offline

#10 2016-09-23 12:41

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

I had previously installed all those packages and still had the errors, but I have just finished a fresh install of Orion and have this time left the kernel as stable. This time I installed the basic desktop profile and after reboot I have the correct screen size and also working sound, however, vlc still fails, this is the output on this fresh install...

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000002405fa8] pulse audio output error: PulseAudio server connection failure: Connection refused
[00000000021e0118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007fb410001268] xcb_xv vout display error: no available XVideo adaptor
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
Segmentation fault

I installed vdpauinfo and ran it in terminal and got this

display: :0   screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

Bearing in mind that I do not have an Nvidia card to you still want me to try the packages you mentioned?

Offline

#11 2016-09-23 12:47

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Yes, please try to install these packages in the correct order and post back the result of vlc run and vdpauinfo for each particular package installed.

Offline

#12 2016-09-23 14:43

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Ok here goes WARNING LONG POST lol

Errors on installation (no extra packages)

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000000d48b98] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000000d1c118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007fcf80001268] xcb_xv vout display error: no available XVideo adaptor
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
Segmentation fault

vdpauinfo

display: :0   screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

INSTALLED vdpau-va-driver

$ sudo apt-get install vdpau-va-driver
Reading package lists... Done
Building dependency tree
Reading state information... Done
vdpau-va-driver is already the newest version.
vdpau-va-driver set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

NO CHANGE SO SKIPPED TESTING FILE

INSTALLED mesa-vdpau-drivers

$ sudo apt-get install mesa-vdpau-drivers
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  mesa-vdpau-drivers
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 1,199 kB of archives.
After this operation, 4,003 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ jessie/main mesa-vdpau-drivers amd64 10.3.2-1+deb8u1 [1,199 kB]
Fetched 1,199 kB in 0s (1,733 kB/s)
Selecting previously unselected package mesa-vdpau-drivers:amd64.
(Reading database ... 76584 files and directories currently installed.)
Preparing to unpack .../mesa-vdpau-drivers_10.3.2-1+deb8u1_amd64.deb ...
Unpacking mesa-vdpau-drivers:amd64 (10.3.2-1+deb8u1) ...
Setting up mesa-vdpau-drivers:amd64 (10.3.2-1+deb8u1) ...
Processing triggers for libc-bin (2.19-18+deb8u6) ...

VLC COMMAND LINE INFO

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[000000000136eb98] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000001342118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007f0114001268] xcb_xv vout display error: no available XVideo adaptor
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
Segmentation fault

VDPAUINFO

display: :0   screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

INSTALLED libvdpau-va-gl1

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  libvdpau-va-gl1
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 40.9 kB of archives.
After this operation, 163 kB of additional disk space will be used.
Get:1 http://ftp.debian.org/debian/ jessie/main libvdpau-va-gl1 amd64 0.3.4-2 [40.9 kB]
Fetched 40.9 kB in 0s (407 kB/s)
Selecting previously unselected package libvdpau-va-gl1:amd64.
(Reading database ... 76602 files and directories currently installed.)
Preparing to unpack .../libvdpau-va-gl1_0.3.4-2_amd64.deb ...
Unpacking libvdpau-va-gl1:amd64 (0.3.4-2) ...
Setting up libvdpau-va-gl1:amd64 (0.3.4-2) ...

VLC COMMAND LINE INFO

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[000000000106bb98] pulse audio output error: PulseAudio server connection failure: Connection refused
[000000000103f118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007fe000001268] xcb_xv vout display error: no available XVideo adaptor
LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb
Segmentation fault

VDPAUINFO

display: :0   screen: 0
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Error creating VDPAU device: 1

INSTALLED nvidia-vdpau-driver

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  dkms fakeroot gcc gcc-4.9 glx-alternative-mesa glx-alternative-nvidia glx-diversions libasan1 libcilkrts5 libegl1-nvidia libfakeroot
  libgcc-4.9-dev libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libjansson4 liblsan0 libnvidia-eglcore libnvidia-ml1 libubsan0
  libxnvctrl0 make nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms
  nvidia-modprobe nvidia-settings nvidia-support pkg-config xserver-xorg-video-nvidia
Suggested packages:
  gcc-multilib autoconf automake libtool flex bison gdb gcc-doc gcc-4.9-multilib gcc-4.9-doc gcc-4.9-locales libgcc1-dbg libgomp1-dbg
  libitm1-dbg libatomic1-dbg libasan1-dbg liblsan0-dbg libtsan0-dbg libubsan0-dbg libcilkrts5-dbg libquadmath0-dbg make-doc
Recommended packages:
  linux-image libgl1-nvidia-glx-i386
The following NEW packages will be installed:
  dkms fakeroot gcc gcc-4.9 glx-alternative-mesa glx-alternative-nvidia glx-diversions libasan1 libcilkrts5 libegl1-nvidia libfakeroot
  libgcc-4.9-dev libgl1-nvidia-glx libgles1-nvidia libgles2-nvidia libjansson4 liblsan0 libnvidia-eglcore libnvidia-ml1 libubsan0
  libxnvctrl0 make nvidia-alternative nvidia-driver nvidia-driver-bin nvidia-installer-cleanup nvidia-kernel-common nvidia-kernel-dkms
  nvidia-modprobe nvidia-settings nvidia-support nvidia-vdpau-driver pkg-config xserver-xorg-video-nvidia
0 upgraded, 34 newly installed, 0 to remove and 0 not upgraded.
Need to get 33.2 MB of archives.
After this operation, 168 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://ftp.debian.org/debian/ jessie/contrib nvidia-installer-cleanup amd64 20141201+1 [20.2 kB]
Get:2 http://ftp.debian.org/debian/ jessie/contrib glx-diversions amd64 0.5.1 [9,432 B]
Get:3 http://ftp.debian.org/debian/ jessie/main libasan1 amd64 4.9.2-10 [195 kB]
Get:4 http://ftp.debian.org/debian/ jessie/main libcilkrts5 amd64 4.9.2-10 [40.1 kB]
Get:5 http://ftp.debian.org/debian/ jessie/contrib glx-alternative-mesa amd64 0.5.1 [3,488 B]
Get:6 http://ftp.debian.org/debian/ jessie/contrib glx-alternative-nvidia amd64 0.5.1 [3,804 B]
Get:7 http://ftp.debian.org/debian/ jessie/contrib nvidia-modprobe amd64 340.46-1 [14.5 kB]
Get:8 http://ftp.debian.org/debian/ jessie/non-free nvidia-alternative amd64 340.96-1 [138 kB]
Get:9 http://ftp.debian.org/debian/ jessie/non-free libnvidia-eglcore amd64 340.96-1 [6,979 kB]
Get:10 http://ftp.debian.org/debian/ jessie/non-free libegl1-nvidia amd64 340.96-1 [288 kB]
Get:11 http://ftp.debian.org/debian/ jessie/contrib nvidia-support amd64 20141201+1 [22.2 kB]
Get:12 http://ftp.debian.org/debian/ jessie/non-free libgl1-nvidia-glx amd64 340.96-1 [7,462 kB]
Get:13 http://ftp.debian.org/debian/ jessie/non-free libgles1-nvidia amd64 340.96-1 [152 kB]
Get:14 http://ftp.debian.org/debian/ jessie/non-free libgles2-nvidia amd64 340.96-1 [155 kB]
Get:15 http://ftp.debian.org/debian/ jessie/main libjansson4 amd64 2.7-1+deb8u1 [34.1 kB]
Get:16 http://ftp.debian.org/debian/ jessie/main liblsan0 amd64 4.9.2-10 [92.8 kB]
Get:17 http://ftp.debian.org/debian/ jessie/non-free libnvidia-ml1 amd64 340.96-1 [416 kB]
Get:18 http://ftp.debian.org/debian/ jessie/main libubsan0 amd64 4.9.2-10 [82.4 kB]
Get:19 http://ftp.debian.org/debian/ jessie/non-free nvidia-driver-bin amd64 340.96-1 [216 kB]
Get:20 http://ftp.debian.org/debian/ jessie/non-free xserver-xorg-video-nvidia amd64 340.96-1 [2,671 kB]
Get:21 http://ftp.debian.org/debian/ jessie/non-free nvidia-vdpau-driver amd64 340.96-1 [974 kB]
Get:22 http://ftp.debian.org/debian/ jessie/main libgcc-4.9-dev amd64 4.9.2-10 [2,066 kB]
Get:23 http://ftp.debian.org/debian/ jessie/main gcc-4.9 amd64 4.9.2-10 [5,352 kB]
Get:24 http://ftp.debian.org/debian/ jessie/main gcc amd64 4:4.9.2-2 [5,136 B]
Get:25 http://ftp.debian.org/debian/ jessie/main make amd64 4.0-8.1 [349 kB]
Get:26 http://ftp.debian.org/debian/ jessie/main dkms all 2.2.0.3-2 [70.9 kB]
Get:27 http://ftp.debian.org/debian/ jessie/contrib nvidia-kernel-common amd64 20141201+1 [11.2 kB]
Get:28 http://ftp.debian.org/debian/ jessie/non-free nvidia-kernel-dkms amd64 340.96-1 [4,037 kB]
Get:29 http://ftp.debian.org/debian/ jessie/non-free nvidia-driver amd64 340.96-1 [422 kB]
Get:30 http://ftp.debian.org/debian/ jessie/main pkg-config amd64 0.28-1 [57.5 kB]
Get:31 http://ftp.debian.org/debian/ jessie/main libxnvctrl0 amd64 340.46-2 [20.7 kB]
Get:32 http://ftp.debian.org/debian/ jessie/contrib nvidia-settings amd64 340.46-2 [720 kB]
Get:33 http://ftp.debian.org/debian/ jessie/main libfakeroot amd64 1.20.2-1 [44.7 kB]
Get:34 http://ftp.debian.org/debian/ jessie/main fakeroot amd64 1.20.2-1 [84.7 kB]
Fetched 33.2 MB in 15s (2,130 kB/s)
Extracting templates from packages: 100%
Preconfiguring packages ...
Selecting previously unselected package nvidia-installer-cleanup.
(Reading database ... 76610 files and directories currently installed.)
Preparing to unpack .../nvidia-installer-cleanup_20141201+1_amd64.deb ...
Unpacking nvidia-installer-cleanup (20141201+1) ...
Setting up nvidia-installer-cleanup (20141201+1) ...
Selecting previously unselected package glx-diversions.
(Reading database ... 76618 files and directories currently installed.)
Preparing to unpack .../glx-diversions_0.5.1_amd64.deb ...
Unpacking glx-diversions (0.5.1) ...
Selecting previously unselected package libasan1:amd64.
Preparing to unpack .../libasan1_4.9.2-10_amd64.deb ...
Unpacking libasan1:amd64 (4.9.2-10) ...
Selecting previously unselected package libcilkrts5:amd64.
Preparing to unpack .../libcilkrts5_4.9.2-10_amd64.deb ...
Unpacking libcilkrts5:amd64 (4.9.2-10) ...
Selecting previously unselected package glx-alternative-mesa.
Preparing to unpack .../glx-alternative-mesa_0.5.1_amd64.deb ...
Unpacking glx-alternative-mesa (0.5.1) ...
Selecting previously unselected package glx-alternative-nvidia.
Preparing to unpack .../glx-alternative-nvidia_0.5.1_amd64.deb ...
Unpacking glx-alternative-nvidia (0.5.1) ...
Selecting previously unselected package nvidia-modprobe.
Preparing to unpack .../nvidia-modprobe_340.46-1_amd64.deb ...
Unpacking nvidia-modprobe (340.46-1) ...
Selecting previously unselected package nvidia-alternative.
Preparing to unpack .../nvidia-alternative_340.96-1_amd64.deb ...
Unpacking nvidia-alternative (340.96-1) ...
Selecting previously unselected package libnvidia-eglcore:amd64.
Preparing to unpack .../libnvidia-eglcore_340.96-1_amd64.deb ...
Unpacking libnvidia-eglcore:amd64 (340.96-1) ...
Selecting previously unselected package libegl1-nvidia:amd64.
Preparing to unpack .../libegl1-nvidia_340.96-1_amd64.deb ...
Unpacking libegl1-nvidia:amd64 (340.96-1) ...
Selecting previously unselected package nvidia-support.
Preparing to unpack .../nvidia-support_20141201+1_amd64.deb ...
Unpacking nvidia-support (20141201+1) ...
Selecting previously unselected package libgl1-nvidia-glx:amd64.
Preparing to unpack .../libgl1-nvidia-glx_340.96-1_amd64.deb ...
Unpacking libgl1-nvidia-glx:amd64 (340.96-1) ...
Selecting previously unselected package libgles1-nvidia:amd64.
Preparing to unpack .../libgles1-nvidia_340.96-1_amd64.deb ...
Unpacking libgles1-nvidia:amd64 (340.96-1) ...
Selecting previously unselected package libgles2-nvidia:amd64.
Preparing to unpack .../libgles2-nvidia_340.96-1_amd64.deb ...
Unpacking libgles2-nvidia:amd64 (340.96-1) ...
Selecting previously unselected package libjansson4:amd64.
Preparing to unpack .../libjansson4_2.7-1+deb8u1_amd64.deb ...
Unpacking libjansson4:amd64 (2.7-1+deb8u1) ...
Selecting previously unselected package liblsan0:amd64.
Preparing to unpack .../liblsan0_4.9.2-10_amd64.deb ...
Unpacking liblsan0:amd64 (4.9.2-10) ...
Selecting previously unselected package libnvidia-ml1:amd64.
Preparing to unpack .../libnvidia-ml1_340.96-1_amd64.deb ...
Unpacking libnvidia-ml1:amd64 (340.96-1) ...
Selecting previously unselected package libubsan0:amd64.
Preparing to unpack .../libubsan0_4.9.2-10_amd64.deb ...
Unpacking libubsan0:amd64 (4.9.2-10) ...
Selecting previously unselected package nvidia-driver-bin.
Preparing to unpack .../nvidia-driver-bin_340.96-1_amd64.deb ...
Unpacking nvidia-driver-bin (340.96-1) ...
Selecting previously unselected package xserver-xorg-video-nvidia.
Preparing to unpack .../xserver-xorg-video-nvidia_340.96-1_amd64.deb ...
Unpacking xserver-xorg-video-nvidia (340.96-1) ...
Selecting previously unselected package nvidia-vdpau-driver:amd64.
Preparing to unpack .../nvidia-vdpau-driver_340.96-1_amd64.deb ...
Unpacking nvidia-vdpau-driver:amd64 (340.96-1) ...
Selecting previously unselected package libgcc-4.9-dev:amd64.
Preparing to unpack .../libgcc-4.9-dev_4.9.2-10_amd64.deb ...
Unpacking libgcc-4.9-dev:amd64 (4.9.2-10) ...
Selecting previously unselected package gcc-4.9.
Preparing to unpack .../gcc-4.9_4.9.2-10_amd64.deb ...
Unpacking gcc-4.9 (4.9.2-10) ...
Selecting previously unselected package gcc.
Preparing to unpack .../gcc_4%3a4.9.2-2_amd64.deb ...
Unpacking gcc (4:4.9.2-2) ...
Selecting previously unselected package make.
Preparing to unpack .../make_4.0-8.1_amd64.deb ...
Unpacking make (4.0-8.1) ...
Selecting previously unselected package dkms.
Preparing to unpack .../dkms_2.2.0.3-2_all.deb ...
Unpacking dkms (2.2.0.3-2) ...
Selecting previously unselected package nvidia-kernel-common.
Preparing to unpack .../nvidia-kernel-common_20141201+1_amd64.deb ...
Unpacking nvidia-kernel-common (20141201+1) ...
Selecting previously unselected package nvidia-kernel-dkms.
Preparing to unpack .../nvidia-kernel-dkms_340.96-1_amd64.deb ...
Unpacking nvidia-kernel-dkms (340.96-1) ...
Selecting previously unselected package nvidia-driver.
Preparing to unpack .../nvidia-driver_340.96-1_amd64.deb ...
Unpacking nvidia-driver (340.96-1) ...
Selecting previously unselected package pkg-config.
Preparing to unpack .../pkg-config_0.28-1_amd64.deb ...
Unpacking pkg-config (0.28-1) ...
Selecting previously unselected package libxnvctrl0.
Preparing to unpack .../libxnvctrl0_340.46-2_amd64.deb ...
Unpacking libxnvctrl0 (340.46-2) ...
Selecting previously unselected package nvidia-settings.
Preparing to unpack .../nvidia-settings_340.46-2_amd64.deb ...
Unpacking nvidia-settings (340.46-2) ...
Selecting previously unselected package libfakeroot:amd64.
Preparing to unpack .../libfakeroot_1.20.2-1_amd64.deb ...
Unpacking libfakeroot:amd64 (1.20.2-1) ...
Selecting previously unselected package fakeroot.
Preparing to unpack .../fakeroot_1.20.2-1_amd64.deb ...
Unpacking fakeroot (1.20.2-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Processing triggers for desktop-file-utils (0.22-1) ...
Processing triggers for mime-support (3.58) ...
Processing triggers for systemd (215-17+deb8u5) ...
Setting up glx-diversions (0.5.1) ...
Adding 'diversion of /usr/lib/libGL.so to /usr/lib/mesa-diverted/libGL.so by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGL.so to /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGL.so to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so by glx-diversions'
Adding 'diversion of /usr/lib/libGL.so.1 to /usr/lib/mesa-diverted/libGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1 to /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGL.so.1 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/libGL.so.1.2 to /usr/lib/mesa-diverted/libGL.so.1.2 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1.2 to /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1.2 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1.2 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1.2 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGL.so.1.2 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1.2 by glx-diversions'
Adding 'diversion of /usr/lib/libGL.so.1.2.0 to /usr/lib/mesa-diverted/libGL.so.1.2.0 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGL.so.1.2.0 to /usr/lib/mesa-diverted/i386-linux-gnu/libGL.so.1.2.0 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGL.so.1.2.0 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGL.so.1.2.0 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGL.so.1.2.0 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGL.so.1.2.0 by glx-diversions'
Adding 'diversion of /usr/lib/libEGL.so to /usr/lib/mesa-diverted/libEGL.so by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libEGL.so to /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libEGL.so to /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libEGL.so to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so by glx-diversions'
Adding 'diversion of /usr/lib/libEGL.so.1 to /usr/lib/mesa-diverted/libEGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libEGL.so.1 to /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libEGL.so.1 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libEGL.so.1 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/libEGL.so.1.0.0 to /usr/lib/mesa-diverted/libEGL.so.1.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libEGL.so.1.0.0 to /usr/lib/mesa-diverted/i386-linux-gnu/libEGL.so.1.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libEGL.so.1.0.0 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libEGL.so.1.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libEGL.so.1.0.0 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libEGL.so.1.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv1_CM.so to /usr/lib/mesa-diverted/libGLESv1_CM.so by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv1_CM.so to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv1_CM.so.1 to /usr/lib/mesa-diverted/libGLESv1_CM.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1 to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so.1 by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv1_CM.so.1.1.0 to /usr/lib/mesa-diverted/libGLESv1_CM.so.1.1.0 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv1_CM.so.1.1.0 to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv1_CM.so.1.1.0 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv1_CM.so.1.1.0 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv1_CM.so.1.1.0 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv1_CM.so.1.1.0 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv1_CM.so.1.1.0 by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv2.so to /usr/lib/mesa-diverted/libGLESv2.so by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv2.so to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv2.so to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv2.so to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv2.so.2 to /usr/lib/mesa-diverted/libGLESv2.so.2 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv2.so.2 to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so.2 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv2.so.2 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so.2 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so.2 by glx-diversions'
Adding 'diversion of /usr/lib/libGLESv2.so.2.0.0 to /usr/lib/mesa-diverted/libGLESv2.so.2.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/i386-linux-gnu/libGLESv2.so.2.0.0 to /usr/lib/mesa-diverted/i386-linux-gnu/libGLESv2.so.2.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/x86_64-linux-gnu/libGLESv2.so.2.0.0 to /usr/lib/mesa-diverted/x86_64-linux-gnu/libGLESv2.so.2.0.0 by glx-diversions'
Adding 'diversion of /usr/lib/arm-linux-gnueabihf/libGLESv2.so.2.0.0 to /usr/lib/mesa-diverted/arm-linux-gnueabihf/libGLESv2.so.2.0.0 by glx-diversions'
Setting up libasan1:amd64 (4.9.2-10) ...
Setting up libcilkrts5:amd64 (4.9.2-10) ...
Setting up glx-alternative-mesa (0.5.1) ...
update-alternatives: using /usr/lib/mesa-diverted to provide /usr/lib/glx (glx) in auto mode
Setting up glx-alternative-nvidia (0.5.1) ...
update-initramfs: deferring update (trigger activated)
Setting up nvidia-modprobe (340.46-1) ...
Setting up nvidia-alternative (340.96-1) ...
Setting up libnvidia-eglcore:amd64 (340.96-1) ...
Setting up nvidia-support (20141201+1) ...
Setting up libjansson4:amd64 (2.7-1+deb8u1) ...
Setting up liblsan0:amd64 (4.9.2-10) ...
Setting up libubsan0:amd64 (4.9.2-10) ...
Setting up libgcc-4.9-dev:amd64 (4.9.2-10) ...
Setting up gcc-4.9 (4.9.2-10) ...
Setting up gcc (4:4.9.2-2) ...
Setting up make (4.0-8.1) ...
Setting up dkms (2.2.0.3-2) ...
Setting up nvidia-kernel-common (20141201+1) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
update-initramfs: deferring update (trigger activated)
Setting up pkg-config (0.28-1) ...
Setting up libxnvctrl0 (340.46-2) ...
Setting up libfakeroot:amd64 (1.20.2-1) ...
Setting up fakeroot (1.20.2-1) ...
Package configuration
                 ┌──────────────────────────────┤ Configuring xserver-xorg-video-nvidia ├───────────────────────────────┐
                 │                                                                                                      │
                 │ Manual configuration required to enable NVIDIA driver                                                │
                 │                                                                                                      │
                 │ The NVIDIA driver is not yet configured; it needs to be enabled in xorg.conf before it can be used.  │
                 │                                                                                                      │
                 │ Please see the package documentation for instructions.                                               │
                 │                                                                                                      │
                 │                                                <Ok>                                                  │
                 │                                                                                                      │
                 └──────────────────────────────────────────────────────────────────────────────────────────────────────┘

Setting up nvidia-driver (340.96-1) ...
Processing triggers for libc-bin (2.19-18+deb8u6) ...
Processing triggers for initramfs-tools (0.120+deb8u2) ...
update-initramfs: Generating /boot/initrd.img-3.16.0-4-amd64
Processing triggers for systemd (215-17+deb8u5) ...

VLC COMMAND LINE INFO (video does play with sound)

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[0000000000abc1c8] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000000a90118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
modprobe: ERROR: could not insert 'nvidia_current': No such device
modprobe: ERROR: could not insert 'nvidia_current': No such device
[00007f6fd8001a28] xcb_xv vout display error: no available XVideo adaptor
[00007f6fd80077e8] glx gl error: cannot create GLX context

VDPAUINFO

display: :0   screen: 0
modprobe: ERROR: could not insert 'nvidia_current': No such device
Error creating VDPAU device: 1

REBOOTED SYSTEM

VLC COMMAND LINE INFO (video does play with sound)

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[000000000152f778] pulse audio output error: PulseAudio server connection failure: Connection refused
[0000000001456118] core libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
modprobe: ERROR: could not insert 'nvidia_current': No such device
modprobe: ERROR: could not insert 'nvidia_current': No such device
[00007fd5c4001268] xcb_xv vout display error: no available XVideo adaptor
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

VDPAUINFO

display: :0   screen: 0
modprobe: ERROR: could not insert 'nvidia_current': No such device
Error creating VDPAU device: 1

At the end of all this vlc does play the videos (with sound) but the error messages are shown in the console. I have not configured the nvidia driver in xorg.conf as I fear it would bork the system (as I don't have nvidia card).

Hope this helps

Offline

#13 2016-09-23 14:57

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Thanks, it helps, we will try to analyze the problem.

Offline

#14 2016-09-23 15:05

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Thanks guy, I have now (--purge) removed the following packages
- mesa-vdpau-drivers
- libvdpau-va-gl1
- nvidia-vdpau-driver
and vlc still plays videos with sound and gives the following as console output (after reboot)

VLC media player 2.2.4 Weatherwax (revision 2.2.3-37-g888b7e89)
[000000000173d848] pulse audio output error: PulseAudio server connection failure: Connection refused
[00000000018f13e8] dummy interface: using the dummy interface module...
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[00007f60f8004ec8] xcb_xv vout display error: no available XVideo adaptor
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
[00007f60f8005158] xcb_window window error: X server failure

Last edited by Dai_trying (2016-09-23 15:06)

Offline

#15 2016-09-26 08:24

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Unrelated posts to this topic has been moved, they continues here http://www.q4os.org/forum/viewtopic.php?id=1069

Please, make your posts related to the original question to keep discussion helpful and clear.

Offline

#16 2016-09-27 19:13

olzeke51
Member
From: So. Carolina, USA
Registered: 2016-08-24
Posts: 22

Re: VLC Crashes

@Dai - what format is the video???  avi , mpeg, wmv!!!,


The journey is . . . the reward.

Offline

#17 2016-09-27 19:44

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

The ones I used for testing were .mp4.

I have found what might be the problem though, I installed inxi and the output of inxi -G is this :-

Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: N/A GLX Version: N/A

So I don't have a GLX renderer avaiable
On my other installation with the stable kernel the output is

Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.16.4 drivers: fbdev,intel (unloaded: vesa) Resolution: 1366x768@0.00hz
           GLX Renderer: N/A GLX Version: N/A

in Scorpion it is

Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.00hz
           GLX Renderer: Mesa DRI Intel HD Graphics 405 (Braswell) GLX Version: 3.0 Mesa 12.0.3

I will have to reboot into scorpion now to check VLC plays the video ok, but I suspect it will.

Offline

#18 2016-09-27 20:37

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

As suspected it plays fine in Scorpion although it also complains about the libvdpau_i965.so not being found.

Anyone know how I can install/configure GLX renderer??

Offline

#19 2016-09-28 19:27

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Please try to run from both installations:
$ sudo apt-get install mesa-utils
$ glxinfo 2>&1 | gzip -f > glxinfo.gz
and attach the 'glxinfo.gz' file here to analyze.

You could also try to run:
$ glxgears
to view simple GLX rendering in action.

Offline

#20 2016-09-28 20:57

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Install 1 (3.16.0-4-amd64)

dai@q4os-desktop:~$ sudo apt-get install mesa-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
mesa-utils is already the newest version.
mesa-utils set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dai@q4os-desktop:~$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
dai@q4os-desktop:~$ glxgears
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't get an RGB, Double-buffered visual

Install 2 (4.6.0-0.bpo.1-amd64)

dai@q4os-desktop:~$ sudo apt-get install mesa-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
mesa-utils is already the newest version.
mesa-utils set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dai@q4os-desktop:~$ glxinfo
name of display: :0
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't find RGB GLX visual or fbconfig
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".

Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
Xlib:  extension "GLX" missing on display ":0".
dai@q4os-desktop:~$ glxgears
Xlib:  extension "GLX" missing on display ":0".
Error: couldn't get an RGB, Double-buffered visual

Exact same on both, I am guessing the kernel is not picking up the video card, and that's the problem but have no clue how to resolve... sad

Just for info I ran the glxinfo in Scorpion in case it can give you some information (file attached)

Last edited by Dai_trying (2016-09-28 21:18)


Attachments:
gz glxinfo.gz, Size: 4.12 KiB, Downloads: 939

Offline

#21 2016-09-29 10:41

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

Please attach the '/var/log/Xorg.0.log' file here. You could also run 'reportq4' tool and attach generated file here, or send it to e-mail support@q4os.org to analyze.

Offline

#22 2016-09-29 11:36

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Reports sent vial email, Thank you.

Offline

#23 2016-09-29 13:30

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 4,343
Website

Re: VLC Crashes

First try to switch the GLX provider to Mesa:
$ sudo update-alternatives --config glx
reboot

Try to run glx utils:
$ glxinfo
$ glxgears

Remove all nvidia components:
$ sudo apt-get autoremove libgl1-nvidia-glx glx-alternative-nvidia nvidia-alternative xserver-xorg-video-nvidia nvidia-settings nvidia-kernel-common nvidia-modprobe nvidia-kernel-dkms

Offline

#24 2016-09-29 14:38

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

Ok, we are making headway, inxi -g reports this

Graphics:  Card: Intel Device 22b1
           Display Server: X.Org 1.16.4 drivers: fbdev,intel (unloaded: vesa) Resolution: 1366x768@0.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 128 bits) GLX Version: 3.0 Mesa 10.3.2

glxgears fails and returns this error

LLVM ERROR: Cannot select: intrinsic %llvm.x86.sse41.pblendvb

glxinfo and qreport.tar.gz sent by email

Offline

#25 2016-10-02 12:18

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,989

Re: VLC Crashes

I have managed to solve this by using the 4.7 kernel and xserver-xorg-video-intel both from backports. I think it may be a case of using Scorpion for newer hardware compatibility but I will keep running this in Orion and see if everything else is ok.

Offline

Board footer

Powered by FluxBB