You are not logged in.

#1 2016-09-12 19:45

davidmen
Member
Registered: 2016-03-18
Posts: 8

90 second delay on shutdown (because of unmounted network shares)

Ciao all, this was happening on an old pc only when connected through wifi: on shutdown there was a long delay due to unmounted network shares (a message "A Stop Job is running for /media/.." and a 90s countdown).
No problem when wired connected or manually unmounting the shares before
It seems it depends on systemd stopping wpa_supplicant.service before unmounting the shares (https://bugzilla.redhat.com/show_bug.cgi?id=1214466)
I edited the file
/usr/lib/systemd/system/wpa_supplicant.service
as per comment #45 in the above link, adding in the [Unit] section
Before=network.target
After=dbus.service
and the problem is solved.
I also checked that wpa_supplicant.service in the updated wpasupplicant_2.5-2+v2.4-2_i386.deb (debian testing) has the entries above, plus an additional
Wants=network.target
(so i guess it's better to add this one too)

Offline

#2 2016-09-12 20:47

Dai_trying
Member
From: UK
Registered: 2015-12-14
Posts: 2,511
Website

Re: 90 second delay on shutdown (because of unmounted network shares)

Nice tip davidmen thanks for sharing it smile

Offline

#3 2016-09-18 10:18

davidmen
Member
Registered: 2016-03-18
Posts: 8

Re: 90 second delay on shutdown (because of unmounted network shares)

Oh, thanks to you Dai, I'm not that expert but I'm happy when i can help this wonderful distro and its great community smile

Offline

Board footer

Powered by FluxBB