You are not logged in.

#1 2022-08-26 08:31

Jilt
Member
Registered: 2022-08-26
Posts: 2

Libreoffice not adding attachment to Thunderbird

Hello,

I have installed your OS on 3 computers in our company, and everything works fine and quick.

However I have an issue with LibreOffice and Thunderbird. What ever I try, it is not possible to send in LibreOffice a document.  Thunderbird does not attach the document to the email. Or does not show up at all.
1. The default Emailhandler = Thunderbird. --> Checked.
2. The default emailsetting in LibreOffice is "sensible-lomua" .
3. Because this was not working changed it to  "/usr/bin/thunderbird" ---> not working.
4. Changed it to "/usr/share/application/thunderbird.desktop" ---->  not working.

This is the case on all 3 computers !!

We are working with 4QOS:
---------------------------------------------------------------------------------------------------
Operating System: Debian GNU/Linux 11
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.10.0-17-amd64
OS Type: 64-bit
Processors: 4 × AMD Ryzen 3 4300U with Radeon Graphics
Memory: 7.2 GiB of RAM
Graphics Processor: AMD RENOIR
-------------------------------------------------------------------------------------------------

Anyone another idea ???

Thanks already

Offline

#2 2022-08-26 13:08

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,644
Website

Re: Libreoffice not adding attachment to Thunderbird

We have done some testing and conclude an upstream bug. This feature doesn't work for Plasma Libreoffice and Thunderbird neither on plain Debian 11 and Kubuntu 22.04. You could report that issue for Debian developers and search for some workaround given by Debian resources. Anyway, thanks for reporting.

If you would find any fix or workaround, you are welcome to share it here.

Last edited by q4osteam (2022-08-26 13:10)

Offline

#3 2022-08-27 06:15

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,200

Re: Libreoffice not adding attachment to Thunderbird

Running Sparkylinux (Debian BUSTER) with XFCE
Libreoffice 7.3.2.2 and Thunderbird
This feature works out of the box - no mess, no fuss.
Tbird is the only mail client installed
Shows as sensible-lomua in Options.

Running Sparkylinux (Debian Testing with MATE DE) in VM.
Libreoffice 7.4.0.3 and Thunderbird
This feature works out of the box - no mess, no fuss.
Tbird is the only mail client installed
Shows as sensible-lomua in Options.

Perhaps this is an issue related to the KDE environment as opposed to the OS?

Offline

#4 2022-08-27 21:09

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,644
Website

Re: Libreoffice not adding attachment to Thunderbird

bin wrote:

Perhaps this is an issue related to the KDE environment as opposed to the OS?

Looks so.

Q4OS 4 Gemini, TDE + XFCE desktop environments installed - the feature works just fine

Offline

#5 2022-08-28 14:40

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,644
Website

Re: Libreoffice not adding attachment to Thunderbird

We have investigated this issue in depth. The culprit is the Apparmor service, particularly "/etc/apparmor.d/usr.lib.libreoffice.program.senddoc" profile, as it's blocking Libreoffice helper scripts in Plasma.

You can workaround the issue the following way:
- disable apparmor service
$ sudo systemctl disable apparmor.service
- set the default e-mail handler in LibreOffice
LibreOffice main menu > Tools > Options > Internet > E-mail > set "/usr/bin/thunderbird"
- reboot
- the feature now works

Anyway, it's a Debian bug and it would deserve a bug report for Debian upstream.

Offline

#6 2022-08-28 16:27

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 1,200

Re: Libreoffice not adding attachment to Thunderbird

Thanks for the informative feedback and the investigation. Not my issue but good to know for next time smile

Offline

#7 2022-08-29 12:04

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 3,644
Website

Re: Libreoffice not adding attachment to Thunderbird

This bug has been added to our official bug tracker https://sourceforge.net/p/q4os/tickets/191/

Offline

Board footer

Powered by FluxBB