You are not logged in.

#1 2018-02-25 05:16

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Sound Problems continue

Guys

I've been a Linux user for 20 years. So I am not exactly a noob.

I know that there are ways to get around sound device problems -- but that is not the point.

I can download virtually any Linux / Unix or Android based system from Distrowatch ---

----and all of them will have sound working straight out of the box.

But NOT Q4OS.

Why is that ?

Why should that even be a problem these days ?

It's not as if I am using weird or old equipment.

I am presently using a HP USDT 8200 i5 with 8Gb of ram

Sound works perfectly with any other system I install --- EXCEPT Q4OS

So please guys --- I love this the Q4OS system

But this is a deal breaker.

I'm sure I am not the only one who is having such problems.

Q

Last edited by Qwertius (2018-02-25 05:18)

Offline

#2 2018-02-25 06:27

Tee
Member
From: Silver Spring, Maryland
Registered: 2018-02-25
Posts: 16

Re: Sound Problems continue

I had audio problems with Q4 until I got Pulse Audio installed I highly recommend Pulse Audio!

Last edited by Tee (2018-02-28 10:12)

Offline

#3 2018-02-25 06:41

Tee
Member
From: Silver Spring, Maryland
Registered: 2018-02-25
Posts: 16

Re: Sound Problems continue

Pulse Audio once I installed it of course it cleared up all the audio issues with Q4...

Last edited by Tee (2018-02-28 10:13)

Offline

#4 2018-02-25 13:40

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

Thanks Tee.

I would move to Q4OS in a heartbeat if this problem was solved.

Nowadays - people expect things to work straight out of the box.

So I hope the creators of this great Distro pick up on this problem.

Cheers

Q

Offline

#5 2018-02-25 14:12

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

PS -- I should have added - that my understanding is that sound is possibly switched off / muted.

Apparently this is done to stop any conflict with existing sound - but I'm not sure.

Perhaps - the settings could be changed so that everything is in the on position rather than being muted or off.

Thanks

Q

Last edited by Qwertius (2018-02-25 14:13)

Offline

#6 2018-02-25 22:43

Tee
Member
From: Silver Spring, Maryland
Registered: 2018-02-25
Posts: 16

Re: Sound Problems continue

Pulse Audio is a network capable sound server program distributed via the freedesktop.org project...

Last edited by Tee (2018-02-28 09:34)

Offline

#7 2018-02-26 08:04

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 702

Re: Sound Problems continue

@Qwertius
Hi - sorry to hear you're having problems with audio on your machine.

First of all a couple of checks.
1. Open Konsole (terminal) and enter

sudo kcmodules --unlock

- this just makes sure all the config tools are available.
2. Open Control Centre>Sound and Multimedia>System Notifications and Click Turn on all sounds>Apply and close
3. Next in Control Centre open Sound and Multimedia>Sound System
4. General Tab - I hope Enable Sound System is checked. If so then uncheck>apply and then check>apply - leave this window open
5. Click the volume control make sure you have a green blob at the top of the slider which should be at 75%
6. On the Sound window click the Test Sound button at the bottom.

This will probably just confirm what we already know but good to make sure.

Next install pavucontrol - either via Synaptic or command - that will bring in the other bits to make Pulse work.

Shut down then switch on again.

Go to the Volume icon , click and open Kmix - that should show that you're running PulseAudio.

Hope that sound is now working.... use the Test Sound button as above but it should have played a start up sound if all is OK.

Offline

#8 2018-02-26 10:05

q4osteam
Q4OS Team
Registered: 2015-12-06
Posts: 2,376
Website

Re: Sound Problems continue

@Qwertius, @Tee
You can safely follow bin's advice from the previous post, thanks bin.

We would recommend you to install the pulseaudio system from package manager or terminal:
$ sudo apt install pulseaudio pavucontrol-qt

We also recommend you to follow audio system troubleshooting from Q4OS documentation https://www.q4os.org/dqa011.html#install.3

Offline

#9 2018-02-26 14:48

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

Thanks to everyone for your help.

The story so far...

Well -- I've managed to get it half working .... lol

The built in speaker works (kinda) -- low volume.

But my plugged in USB connected Logitec Headphones are doing nothing.

I have downloaded & installed Pulse and it also installed pavucontrol of its own accord.

Restarted --- sound works - but not with my headphones.

The system can 'see' them ------- but nothing is happening.

I switched off 'auto-suspend' but beyond that everything is stock standard.

So over to you kind gentlemen

Cheers

Q

Update --- now the sound has stopped all together.

Hmmm.....

Last edited by Qwertius (2018-02-26 15:12)

Offline

#10 2018-02-26 16:02

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 702

Re: Sound Problems continue

Open Pulse Audio Volume Control - should be under Multimedia depending on which menu system you use.
Plug in headphones and make sure the Output device tab Port changes to Headphones - do the sliders have any effect?

If not, then the next bit is some more info about the system.

sudo apt-get install inxi

Then please run

inxi -F

and copy/paste the output back here for the next round.

Offline

#11 2018-02-27 19:29

Tee
Member
From: Silver Spring, Maryland
Registered: 2018-02-25
Posts: 16

Re: Sound Problems continue

Qwertius I am interested in how u made out?...I got Pulse Audio Volume Control installed and its working great!

Last edited by Tee (2018-02-28 09:35)

Offline

#12 2018-02-27 21:36

altesack
Member
Registered: 2018-02-27
Posts: 1

Re: Sound Problems continue

Hello from Frankfurt
I`m  just two min. old reg.user.
V3.1 installed pavu cntrl,clicked from cntrls> sound systm >hardware, there is a little part : my systm is german and it says "Eigene Hardware-Gerätedatei verwenden  (It means I think use your own hardware:) writedown pavucontrol make it activ and t works.

congrats to devs. really beautiful os. i use scorpion 2 months now and i like it.(Iḿ a long time deb and sometimes arch user+ old crunchbang.

Offline

#13 2018-03-01 08:27

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

bin wrote:

Open Pulse Audio Volume Control - should be under Multimedia depending on which menu system you use.
Plug in headphones and make sure the Output device tab Port changes to Headphones - do the sliders have any effect?

If not, then the next bit is some more info about the system.

sudo apt-get install inxi

Then please run

inxi -F

and copy/paste the output back here for the next round.

Here is the output
qwertius@q4os-desktop:~$ inxi -F
System:    Host: q4os-desktop Kernel: 4.9.0-6-amd64 x86_64 (64 bit)
           Desktop: KDE Plasma 3 Distro: Debian GNU/Linux 9 (stretch)
Machine:   Device: desktop System: Hewlett-Packard product: HP Compaq 8200 Elite
USDT PC
           Mobo: Hewlett-Packard model: 1496
           BIOS: Hewlett-Packard v: J01 v02.15 date: 11/10/2011
CPU:       Quad core Intel Core i5-2400S (-MCP-) cache: 6144 KB
           clock speeds: max: 3300 MHz 1: 1786 MHz 2: 1654 MHz 3: 1697 MHz
           4: 1687 MHz
Graphics:  Card: Intel 2nd Generation Core Processor Family Integrated Graphics                                                    Controller
           Display Server: X.Org 1.19.2 drivers: modesetting (unloaded: fbdev,ve                                                   sa)
           Resolution: 1280x1024@60.02hz
           GLX Renderer: Mesa DRI Intel Sandybridge Desktop
           GLX Version: 3.0 Mesa 13.0.6
Audio:     Card-1 Intel 6 Series/C200 Series Family High Definition Audio Contro                                                   ller
           driver: snd_hda_intel
           Card-2 Logitech ClearChat Pro USB driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.9.0-6-amd64
Network:   Card: Intel 82579LM Gigabit Network Connection driver: e1000e
           IF: eno1 state: up speed: 100 Mbps duplex: full
           mac: 9c:8e:99:e4:ef:d6
Drives:    HDD Total Size: 320.1GB (19.3% used)
           ID-1: /dev/sda model: ST320LT007 size: 320.1GB
Partition: ID-1: / size: 20G used: 3.2G (17%) fs: ext4 dev: /dev/loop0
Sensors:   System Temperatures: cpu: 37.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 159 Uptime: 20 min Memory: 628.7/7875.6MB
           Client: Shell (bash) inxi: 2.3.5
qwertius@q4os-desktop:~$

Last edited by Qwertius (2018-03-01 13:36)

Offline

#14 2018-03-01 10:58

bin
Member
From: U.K.
Registered: 2016-01-28
Posts: 702

Re: Sound Problems continue

OK - so have you installed pulseaudio yet?

Quick search reveals a whole number of issues being raised about Logitech ClearChat Pro USB and Headphones.

I know one or two other major contributors on this forum have better audio skills that me, sorry but from here on I'd just be guessing.

Offline

#15 2018-03-01 13:39

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

Hi Bin,

Yes -- I have installed PulseAudio.

Logitec --- I am beginning to wonder....

It would be my sort of luck....

Q

Last edited by Qwertius (2018-03-01 13:48)

Offline

#16 2018-03-01 14:07

Qwertius
Member
Registered: 2017-10-24
Posts: 18

Re: Sound Problems continue

Update ----

I think I might have solved the problem. But I am not sure.

I am getting sound out of my Logitec Earphones.

I went to 'Output devices'   in the 'Volume Control' panel.

What I did -- was select 'Speakers' in the top set of options.

The sound now comes out of the earphones. (strange)

I'm hoping this has solved the problem.

Fingers crossed.

Q

Last edited by Qwertius (2018-03-01 14:49)

Offline

Board footer

Powered by FluxBB